Bug 192976 - Ignores ButtonRelease event if ButtonPressMask is not in XSelectInput() function
Summary: Ignores ButtonRelease event if ButtonPressMask is not in XSelectInput() function
Status: CLOSED DUPLICATE of bug 192975
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity   
(Show other bugs)
Version: 5
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL: http://groups.google.com/group/comp.w...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-24 16:03 UTC by Ashish Shukla
Modified: 2014-06-18 09:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 03:09:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The source code of the test app (1.50 KB, text/x-csrc)
2006-05-24 16:03 UTC, Ashish Shukla
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 304430 None None None Never

Description Ashish Shukla 2006-05-24 16:03:39 UTC
Description of problem:
The window manager doesn't forwards any 'ButtonRelease' event to app, if 
'ButtonPressMask' is not passed in 'XSelectInput()' Xlib routine.

Version-Release number of selected component (if applicable):
metacity-2.14.3-1.fc5.1

How reproducible:
Just compile and run the app in the following comp.window.x thread:
http://groups.google.com/group/comp.windows.x/browse_frm/thread/bfe8d4e856d6a592/a9072bf02a35955f#a9072bf02a35955f

Steps to Reproduce:
1. Try releasing mouse button on the app's window
2. If window gets destroyed, this means WM is fine
3. If window doesn't destroys, it means WM is not forwarding
  
Actual results:
'ButtonRelease' event is not forward to the app by WM, and hence unable to 
catch any 'ButtonRelease' events. If 'ButtonPressMask' is also passed in the 
'XSelectInput()' routine, then only 'ButtonRelease' event fires.

Expected results:
'ButtonRelease' event should be forwarded to the app, if 'ButtonReleaseMask' 
is passed in 'XSelectInput()' Xlib routine.

Additional info:
I've also posted in GNOME Bugzilla, but as a comment to existing similar 
looking Bugreport. Attached is the source code of the app I'm trying to 
execute.

Comment 1 Ashish Shukla 2006-05-24 16:03:39 UTC
Created attachment 129947 [details]
The source code of the test app

Comment 2 Søren Sandmann Pedersen 2006-09-08 03:09:48 UTC

*** This bug has been marked as a duplicate of 192975 ***


Note You need to log in before you can comment on or make changes to this bug.