Bug 192986 - e-d-s crashes when using the search functionality in the task view within Evolution
e-d-s crashes when using the search functionality in the task view within Evo...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 12:54 EDT by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 13:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace of unwelcome crash (2.14 KB, text/plain)
2006-09-18 17:45 EDT, David Nielsen
no flags Details
new backtrace (11.88 KB, text/plain)
2006-09-21 15:28 EDT, David Nielsen
no flags Details

  None (edit)
Description David Nielsen 2006-05-24 12:54:39 EDT
Description of problem:
evolution-data-server crashes when using the search functionality in the task
view within Evolution.

Version-Release number of selected component (if applicable):
evolution-2.7.2.1-3
evolution-data-server-1.7.2-1

How reproducible:
100%

Steps to Reproduce:
1. start up evolution
2. switch to task view
3. enter search term
4. hit enter or preform search
  
Actual results:
evolution-data-server reportedly crashes

Expected results:
search result returned succesfully
Comment 1 Matthew Barnes 2006-05-24 16:20:11 EDT
I was able to reproduce this on an x86_64 machine, but not on a i386.  Both
machines were running evolution-2.7.2.1 and evolution-data-server-1.7.2.  Will
investigate further.
Comment 2 Matthew Barnes 2006-09-18 14:06:32 EDT
I can no longer reproduce this at all with evolution-2.8.0 and
evolution-data-server-1.8.0.

David, are you still seeing this problem?
Comment 3 David Nielsen 2006-09-18 15:30:12 EDT
I am indeed still seeing a crash while doing a search in the task context. What
information do you require my good sir and I shall provide
Comment 4 Matthew Barnes 2006-09-18 15:44:04 EDT
A backtrace for evolution-data-server would be very helpful.  My access to a
64-bit machine is pretty limited at the moment.  TIA.

Probably easiest to attach GDB to a running session:
$ gdb --pid `/sbin/pidof evolution-data-server-1.8`
Comment 5 David Nielsen 2006-09-18 17:45:33 EDT
Created attachment 136587 [details]
backtrace of unwelcome crash

I'm unsure if this is indeed the crash we want because now it crashes when I
switch to the task view rather than search and my tasks are all gone. I did a
evolution --force-shutdown to ensure a clean restart and the same thing
happened.
Comment 6 Matthew Barnes 2006-09-21 15:13:50 EDT
It doesn't look like the backtrace is showing a crash.  All three threads are
stuck in __GI___poll().  Did the attachment get clipped somehow?
Comment 7 David Nielsen 2006-09-21 15:28:28 EDT
Created attachment 136903 [details]
new backtrace

Maybe, I recaptured the crash with bug-buddy in the hope that this time the
backtrace might be useful.
Comment 8 David Nielsen 2007-06-06 13:12:36 EDT
This one seems to have gone away.

Note You need to log in before you can comment on or make changes to this bug.