Bug 193002 - ijs-gimp-print sending an empty document (stdin) at session start
ijs-gimp-print sending an empty document (stdin) at session start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gimp-print (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 13:51 EDT by Gian Paolo Mureddu
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 10:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2006-05-24 13:51:15 EDT
Description of problem:
ijs-gimp-print will take 100% processor use at session start up, when killed
then the gnome-print manager opens and there is a document of size unknown sent
to the spool, if I turn on the printer, it will start spiting pages of paper
without printing anything. This has happened with two printers: Lexmark Z53 with
Fedora Core 5 x86_64 and an Epson R300 Photo with i386 Fedora Core 3, there have
been recent CUPS and gimp pacakges updates. The printers will keep on printing
even after turning them off and then back on, the print job can't be cancelled
from gnome's print systray icon, and when trying to execute lprm or any of the
lp commands to see what's the print job or try to stop it, it won't respond with
the message "could not connect to server" or something similar (in spanish: No
se ha podido conectar al servidor")

Version-Release number of selected component (if applicable):
gimp-print-4.2.7-16

How reproducible:
Always.

Steps to Reproduce:
1. Start the system.
2. Start a session.
  
Actual results:
The ijsgimpprint program will send an unknown document to print, which is empty
and the printer will start spitting out pages (i.e, "the printer's gone crazy").

Expected results:
The printer to activate when a user actually sends a print job.

Additional info:
This problem has shown in two distributions with different printers and
different networks and physical locations (i.e not in the same building) after
pressumably applying a series of updates.

Upon execution of ps aux | lp, I found this on the Fedora Core 5 machine (will
have to confirm this on the Core 3 one, though):

lp        3117  0.0  0.1  15976  1164 ?        S    12:33   0:00
hal:///org/freedesktop/Hal/devices/usb_device_43d_54_noserial_if0_printer_noserial
19 gianni (stdin) 1 cpi=12 scp-fc5 lpi=7 page-bottom=86 page-left=57
page-right=57 page-top=72 scaling=100 wrap
job-uuid=urn:uuid:cbe68642-078c-3b46-61ed-67d873c38348

After a while this message disappeared and the printer "got back to normal".

Another thing that both machines have in common is a wireless keyboard which for
some reason spits a lot of messages about atkbd.c:

Unknown key pressed (translated set 2, code 0xd9 on isa0060/serio0).
atkbd.c: Use 'setkeycodes e059 <keycode>' to make it known.

The keyboards are diferent brands (one Microsoft, one Genius) and both have
multimedia keys.

Needless to say this is a rather strange problem... Especially one that
apparently hasn't struck too many users.
Comment 1 Tim Waugh 2006-12-15 07:45:24 EST
Are you still able to reproduce this problem?
Comment 2 Gian Paolo Mureddu 2006-12-15 14:10:01 EST
No, the machines have since been updated to Fedora Core 6 (x86_64 and i386
versions). One thing, though, apparently the problem got fixed on FC5 with the
release of a CUPS update (CUPS especially and not gimp-print). As I'm the
responsible for those machines, maybe I made a configuration mistake (I couldn't
see how, though).

Note You need to log in before you can comment on or make changes to this bug.