Bug 1930106 - Cannot IPI with tang/tpm disk encryption
Summary: Cannot IPI with tang/tpm disk encryption
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Yuval Kashtan
QA Contact: Ori Michaeli
URL:
Whiteboard:
Depends On: 1928537
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-18 11:22 UTC by Yuval Kashtan
Modified: 2021-03-30 04:47 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: installer requesting older (v3.1) ignition version while RHCOS already moved to 3.2. Consequence: cannot install OCP with disk encryption Fix: bump ignition version to 3.2 Result: LUKS section of ignition is being processed.
Clone Of: 1928537
Environment:
Last Closed: 2021-03-30 04:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4701 0 None open Bug 1930106: bump ignition to v3_2 2021-03-17 20:51:39 UTC
Red Hat Product Errata RHSA-2021:0957 0 None None None 2021-03-30 04:47:52 UTC

Comment 1 Kiran Thyagaraja 2021-02-22 19:36:47 UTC
Looks like your PR went through. Is this issue now resolved after updating Ignition version in the installer?

Comment 2 Yuval Kashtan 2021-02-22 22:18:51 UTC
my pr was for master (4.8)
now need to backport to 4.7
and get it in 4.7.z IMHO

otherwise, still cant get LUKS encryption in 4.7

Comment 3 Stephen Benjamin 2021-03-01 19:47:13 UTC
@Yuval: The automatic cherry-pick failed on GitHub, will you resolve the conflicts and open a PR manually?
See: https://github.com/openshift/installer/pull/4653#issuecomment-781261932

Comment 4 Yuval Kashtan 2021-03-02 12:37:36 UTC
https://github.com/openshift/installer/pull/4701

Comment 6 Yuval Kashtan 2021-03-08 20:51:13 UTC
hopefully EOD tomorrow
but I'm still waiting on QE to verify the 4.8 fix (can't merge the backport before that)

Comment 11 errata-xmlrpc 2021-03-30 04:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Moderate: OpenShift Container Platform 4.7.4 security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2021:0957


Note You need to log in before you can comment on or make changes to this bug.