Bug 1930298 - 'NUMA Node Count' number is not set if at the same editing the user sets vcpu pinning.
Summary: 'NUMA Node Count' number is not set if at the same editing the user sets vcpu...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.4.4.5
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: ovirt-4.4.7
: 4.4.7.1
Assignee: Liran Rotenberg
QA Contact: Polina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-18 16:38 UTC by Polina
Modified: 2021-07-06 07:28 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.4.7.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 07:28:25 UTC
oVirt Team: Virt
pm-rhel: ovirt-4.4+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 114932 0 master MERGED webadmin: prevent numa reset 2021-06-02 12:39:42 UTC

Description Polina 2021-02-18 16:38:08 UTC
Description of problem:'NUMA Node Count' number is not set when editing includes vcpu pinning


Version-Release number of selected component (if applicable):
ovirt-engine-4.4.5.5-0.13.el8ev.noarch

How reproducible:100%


Steps to Reproduce:
0. Setup must have host supporting NUMA arch
1. Create a VM on the base of infra template and open Edit window.
2. System tab - configure 8 CPUs
3. Host tab - pin to the numa host and set 1 'NUMA Node Count'.
4. Resource Allocation tab - enter some vcpu pinning string , like 0#0_1#1
5. OK in the dialog and re-open 

Actual results: 'NUMA Node Count' = 0


Expected results:'NUMA Node Count' = 1


Additional info: the bug doesn't happen if we don't configure vcpu pinning

Comment 1 Polina 2021-06-21 10:23:04 UTC
verified on ovirt-engine-4.4.7.4-0.9.el8ev.noarch

Comment 2 Sandro Bonazzola 2021-07-06 07:28:25 UTC
This bugzilla is included in oVirt 4.4.7 release, published on July 6th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.