Bug 1930347 - WMCO is unable to display filesystem graphs for Windows Nodes
Summary: WMCO is unable to display filesystem graphs for Windows Nodes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Windows Containers
Version: 4.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Team Windows Containers
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-18 17:28 UTC by vhire@redhat.com
Modified: 2022-08-22 17:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-22 17:10:39 UTC
Target Upstream Version:


Attachments (Terms of Use)
Actual results for console graphs (33.90 KB, image/png)
2021-02-18 17:28 UTC, vhire@redhat.com
no flags Details

Description vhire@redhat.com 2021-02-18 17:28:45 UTC
Created attachment 1757868 [details]
Actual results for console graphs

Description of problem:

WMCO uses existing console queries to display graphs for Windows nodes. Changes in filesystem queries(https://github.com/openshift/console/pull/7201) on the console side, prevents filesystem graphs to be displayed for Windows nodes. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Deploy 2.0+ version of WMCO 
2.Create MachineSet
3.Observe console graphs when the Node bootstrap is completed successfully 

Actual results:
All node graphs visible except for Filesystem graphs.

Expected results:
All node graphs visible for Windows nodes

Additional info:

The reason for filesystem queries to not work is windows_exporter is not returning any values for `mountpoint` field which is being used in the updated queries.

Comment 2 vhire@redhat.com 2021-02-18 18:46:41 UTC
As a part of this fix, to avoid breakage in future by query updates, add Windows test to the console(https://github.com/openshift/console) repo.

Comment 4 jvaldes 2022-08-22 17:10:39 UTC
This work is tracked by https://issues.redhat.com/browse/WINC-590


Note You need to log in before you can comment on or make changes to this bug.