Bug 1930514 - Plasma System Monitor don't show neither History nor System Stats
Summary: Plasma System Monitor don't show neither History nor System Stats
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-systemmonitor
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact:
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
Depends On:
Blocks: F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-02-19 03:51 UTC by Geraldo Simião
Modified: 2021-03-12 01:35 UTC (History)
10 users (show)

Fixed In Version: plasma-systemmonitor-5.21.2-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-12 01:35:20 UTC
Type: Bug


Attachments (Terms of Use)
Overview of the Plasma System Monitor - without data (78.09 KB, image/png)
2021-02-19 03:51 UTC, Geraldo Simião
no flags Details
History tab on the new plasma system monitor - blank (71.75 KB, image/png)
2021-02-19 03:53 UTC, Geraldo Simião
no flags Details
System settings showing that KSYSGUARDD still active on this build (224.27 KB, image/png)
2021-02-19 03:54 UTC, Geraldo Simião
no flags Details
Tried to search for the new KSystemStats service but none found (60.62 KB, image/png)
2021-02-19 03:56 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2021-02-19 03:51:29 UTC
Created attachment 1757981 [details]
Overview of the Plasma System Monitor - without data

Description of problem:
Testing the Fedora-KDE-Live-x86_64-34-20210217.n.0.iso I found that when opening the new Plasma System Monitor its doesn't show History (CPU, Memory or Network) information and it doesn't show System Stats (on the overview tab)(prints of the screens attached). I tried on wayland and x11 session too.

Version-Release number of selected component (if applicable):
Fedora 34 build => Fedora-KDE-Live-x86_64-34-20210217.n.0.iso
KDE frameworks => 5.79.0
Qt => 5.15.2
Kernel => 5.11.0-0.rc7 (150)

How reproducible:
Allways


Steps to Reproduce:
1.Login to a session (wayland or x11)
2.Open Plasma System Monitor from the menu
3.Browse through the tabs overview and history

Actual results:
Blank data on both screens

Expected results:
Actual data on memory, disks, CPU and Network usage.

Additional info:
I found that the old KSYSGUARD DEMON still running (as see on the image attached), but no KSystemStats (print attached).
Seems that the service KSystemStats its not on this build.
I tried this on a vm, and on baremetal too, both failed to show data. I asked a friend fedoran to test too, downloading a new iso and he have confirmed my results.

Comment 1 Geraldo Simião 2021-02-19 03:53:29 UTC
Created attachment 1757982 [details]
History tab on the new plasma system monitor - blank

Comment 2 Geraldo Simião 2021-02-19 03:54:53 UTC
Created attachment 1757983 [details]
System settings showing that KSYSGUARDD still active on this build

Comment 3 Geraldo Simião 2021-02-19 03:56:01 UTC
Created attachment 1757984 [details]
Tried to search for the new KSystemStats service but none found

Comment 4 Fedora Update System 2021-02-28 15:46:38 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 5 Fedora Blocker Bugs Application 2021-02-28 15:49:53 UTC
Proposed as a Blocker for 34-final by Fedora user ngompa using the blocker tracking app because:

 This violates the Fedora final release criterion for default application functionality: "All applications that can be launched using the standard graphical mechanism after a default installation [...] on the x86_64 architecture must start successfully and withstand a basic functionality test."

Comment 6 Fedora Update System 2021-02-28 19:12:55 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 nucleo 2021-03-01 01:40:07 UTC
with ksysguard-5.21.1-2.fc34 there two ksysguard-libs is in repo ksysguard-libs-4.11.22-29.fc34 and ksysguard-libs-5.21.1-2.fc34
https://koji.fedoraproject.org/koji/buildinfo?buildID=1681160

Comment 8 Kamil Páral 2021-03-01 16:15:53 UTC
Since the update is already available (sans some dependency issues which need to be figured out), proposing as a Beta freeze exception.

Comment 9 Adam Williamson 2021-03-01 16:59:20 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/262 , marking accepted.

Comment 10 Fedora Update System 2021-03-01 17:55:58 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 11 Geoffrey Marr 2021-03-01 21:28:39 UTC
Discussed during the 2021-03-01 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Final)" was made as the cited criterion is qualified on KDE to only cover a limited range of application types, and the system monitor is not one of them.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-03-01/f34-blocker-review.2021-03-01-17.01.txt

Comment 12 Adam Williamson 2021-03-02 01:43:04 UTC
I'm not really inclined to pull an entire new release of Plasma just to fix this bug...

Comment 13 Fedora Update System 2021-03-02 04:31:04 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2021-03-02 04:44:47 UTC
FEDORA-2021-4cb70a50e5 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

Comment 15 Fedora Update System 2021-03-03 15:42:53 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-4cb70a50e5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-4cb70a50e5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Lukas Ruzicka 2021-03-08 13:06:59 UTC
I can confirm, the System Monitor now shows data on the History tab.

Comment 17 Geraldo Simião 2021-03-09 11:53:52 UTC
Yes, with the updates, now system monitor works as expected. Hope the update reaches stable soon, so it can be part of the new ISOs.

Comment 18 Fedora Update System 2021-03-12 01:35:20 UTC
FEDORA-2021-4cb70a50e5 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.