Bug 19306 - 7.0 kudzu won't recompile on RHL6.2
7.0 kudzu won't recompile on RHL6.2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 02:19 EDT by Pekka Savola
Modified: 2014-03-16 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 02:19:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-10-18 02:19:13 EDT
7.0 Kudzu (which is required by Xconfigurator, which is required by
XFree86-4) won't
recompile in RHL 6.2

The reason is a minor change in the naming of headers (linux/hdreg.h).  The
following makes it compile
fine.  A check for the struct member should probably be there somewhere:

--- ide.c~	Tue Aug  8 23:11:08 2000
+++ ide.c	Wed Oct 18 08:48:17 2000
@@ -211,7 +211,7 @@
 
 		if (!ioctl(fd, CDROMVOLCTRL, &vol))
 			newdev->class = CLASS_CDROM;
-		else if (hdId.command_set_1 & 4)
+		else if (hdId.command_sets & 4)
 			newdev->class = CLASS_FLOPPY;
 		else
 			newdev->class = CLASS_HD;
Comment 1 Bill Nottingham 2000-10-18 02:33:57 EDT
This got fixed in kudzu-0.75.

Note You need to log in before you can comment on or make changes to this bug.