Bug 193085 - rpm fails to install new kernel
rpm fails to install new kernel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 21:46 EDT by Barry K. Myrvold
Modified: 2008-05-06 11:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 11:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Myrvold 2006-05-24 21:46:24 EDT
Description of problem:

when I run 'sudo yum update' yum will update all files except it stalls in the
middle of installing a new kernel. Likewise when I run 'sudo rpm -ivh kernel...'
for any new kernel rpm stalls half way through.  Has done so with virtually all
kernels since installed Fedora Core 5. 

Version-Release number of selected component (if applicable):

yum 2.6.1
rpm 4.4.2

How reproducible:

run 'yum update' and try to install a new kernel
or run 'rpm -ivh kernel...' for any new kernel

Steps to Reproduce:
1. sudo yum update
2. sudo rpm -ivh kernel...
3.
  
Actual results:

stalls in the middle of installing new kernel

Expected results:

a new kernel

Additional info:
According to rpm -ihvv, here's where it stalls
+ /sbin/new-kernel-pkg --package kernel-smp --mkinitrd --depmod --install
2.6.16-1.2122_FC5smp
I have enough room in my /boot partition.

There is a message in /var/log/messages that may be related - it is

May 24 21:00:12 localhost kernel: loop: loaded (max 8 devices)
Comment 1 Paul Nasrat 2006-05-25 08:36:32 EDT
Yes indeed you don't have any free loop devices so we can't create the initrd.

Is there any way we can detect this in the scripts and bail appropriately.
Comment 2 Bug Zapper 2008-04-03 22:58:20 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 3 Bug Zapper 2008-05-06 11:56:42 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.