Bug 193087 - Abort while playing haxima
Abort while playing haxima
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nazghul (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 01:21 EDT by Jerry James
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.3-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-08 10:29:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace showing abort (4.00 KB, text/plain)
2006-05-25 01:21 EDT, Jerry James
no flags Details

  None (edit)
Description Jerry James 2006-05-25 01:21:50 EDT
Description of problem:
I was in the wilderness near the Enchanter's Tower.  I tried to attack a nearby
wolf pack, and the game aborted.

Version-Release number of selected component (if applicable):
nazghul-0.5.3-4.fc5

How reproducible:
Once only.

Steps to Reproduce:
1. I have not been able to reproduce the crash.
2.
3.
  
Actual results:
The game aborted.

Expected results:
The game should have continued playing.

Additional info:
I will attach a backtrace from the generated core file.
Comment 1 Jerry James 2006-05-25 01:21:50 EDT
Created attachment 129974 [details]
Backtrace showing abort
Comment 2 Jason Tibbitts 2006-05-25 11:18:59 EDT
I'll pass this upstream and let you know if I hear anything.  Thanks for
including the backtrace; that will help immensely.
Comment 3 Jason Tibbitts 2006-05-25 23:40:29 EDT
Upstream is working on a fix which I will backport to FC5.  (An update would
most likely break your saves.)

However, to help narrow things down a bit, is there a possibility that you were
attempting to attack on a diagonal?
Comment 4 Jerry James 2006-06-07 15:17:06 EDT
Sorry to be so slow replying.  I was traveling.  Yes, I believe I did attempt to
attack on a diagonal.  Apparently that's not allowed. :-)

As for an update breaking my saves, I wouldn't worry about that.  For one thing,
the game has been in Fedora Extras for such a short time that there probably
aren't a lot of people with save files yet.  For another, if there is a new
version in the works with a different save file format, I prefer to move to it
sooner rather than later to get the migration pain over with.  Waiting will only
increase the number of people affected.

Thanks for your help.
Comment 5 Jason Tibbitts 2006-06-08 10:29:58 EDT
Yes, attacking on a diagonal in the wilderness doesn't work at present because
the combat map generator doesn't handle that case.  I have added a fix that
prevents such attacks and pushed new builds; they should make it out to the
mirrors by tomorrow.  If you find you still have this issue, please let me know.


Note You need to log in before you can comment on or make changes to this bug.