Bug 193112 - /usr/sbin/module_upgrade segfaults
/usr/sbin/module_upgrade segfaults
Status: CLOSED DUPLICATE of bug 190938
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 07:16 EDT by Ian Collier
Modified: 2014-03-16 22:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 12:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Collier 2006-05-25 07:16:46 EDT
Description of problem:
/usr/sbin/module_upgrade is run in the post-install script when installing
kernels.  If there's a bad line in /etc/modprobe.conf, it segfaults (and it's
quite tricky to track down).  The bad line in my case was left over from an
earlier Red Hat version which I upgraded to FC5 (rather than doing a fresh
install, as I would if this weren't a test machine).

Version-Release number of selected component (if applicable):
kudzu-1.2.34.3-1

How reproducible:
Always

Steps to Reproduce:
1. Have this line in /etc/modprobe.conf:
alias usb-controller usb-uhci
2. /usr/sbin/module_upgrade
  
Actual results:
Segmentation fault

Expected results:
Not a segmentation fault. :-)

Additional info:
Program received signal SIGSEGV, Segmentation fault.
0x00f263da in strcmp () from /lib/libc.so.6
(gdb) bt
#0  0x00f263da in strcmp () from /lib/libc.so.6
#1  0x0804ae1c in main (argc=761881448, argv=0x646368) at module_upgrade.c:252
#2  0x00ed670e in __libc_start_main () from /lib/libc.so.6
#3  0x0804a4b1 in _start ()
(gdb) up
#1  0x0804ae1c in main (argc=761881448, argv=0x646368) at module_upgrade.c:252
252                                         if (!strcmp(l->newnames[i],
tmpdev->driver)) {
(gdb) print *tmpdev
$1 = {next = 0x9b73a80, index = 1, type = CLASS_OTHER, bus = BUS_PCI, 
  device = 0x0, driver = 0x0, 
  desc = 0x9b73a30 "Intel Corporation 82371AB/EB/MB PIIX4 ISA", detached = 0, 
  classprivate = 0x0, newDevice = 0x804fda0 <pciNewDevice>, 
  freeDevice = 0x804fc90 <pciFreeDevice>, 
  writeDevice = 0x804ff60 <pciWriteDevice>, 
  compareDevice = 0x804fe80 <pciCompareDevice>}
Comment 1 Bill Nottingham 2006-05-25 12:30:38 EDT

*** This bug has been marked as a duplicate of 190938 ***

Note You need to log in before you can comment on or make changes to this bug.