Bug 193125 - ImageMagick broken: tools can't work with .JPG files
ImageMagick broken: tools can't work with .JPG files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
5
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 10:43 EDT by Dan O'Brien
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 12:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan O'Brien 2006-05-25 10:43:26 EDT
Description of problem:

Latest update of ImageMagick tools is broken, at least with JPG flies.

Version-Release number of selected component (if applicable):

Name        : ImageMagick                  Relocations: (not relocatable)
Version     : 6.2.5.4                           Vendor: Red Hat, Inc.
Release     : 4.2.1.fc5.2                   Build Date: Wed 24 May 2006 11:25:54

How reproducible:

all tools have trouble with JPG. other formats not tested.

Steps to Reproduce:
1. display jjj.JPG
2. display: no decode delegate for this image format
3.
  
Actual results:

$ display DSCN0122.JPG 
display: no decode delegate for this image format `DSCN0122.JPG'.
display: unable to open image `logo:': No such file or directory.
$ identify DSCN0122.JPG
identify: no decode delegate for this image format `DSCN0122.JPG'.
$ convert -rotate 270 DSCN0122.JPG ~/image.jpg
convert: no decode delegate for this image format `DSCN0122.JPG'.
$ file DSCN0122.JPG
DSCN0122.JPG: JPEG image data, EXIF standard


Expected results:


Additional info:
Comment 1 John Hodrien 2006-05-25 12:11:03 EDT
Confirmed on multiple machines here running FC5 x86_64.  Note it's even broken
if you don't open an image:

$ display
display: unable to open image `logo:': No such file or directory.

$ display 2006-14-a-full_tif.tif
display: no decode delegate for this image format `2006-14-a-full_tif.tif'.
display: unable to open image `logo:': No such file or directory.
Comment 2 Dan O'Brien 2006-05-25 13:26:55 EDT
Looks like some configure parm was messed up:

$ strace -f -o out convert -rotate 90 unit.jpg unit2.jpg

$ tail -15 out
30141 _llseek(3, 0, [7710], SEEK_END)   = 0
30141 mmap2(NULL, 7710, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7fc2000
30141 munmap(0xb7fc2000, 7710)          = 0
30141 close(3)                          = 0
30141 open("/usr/share/ImageMagick-6.2.5/config/delegates.xml",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
30141 open("/usr/share/doc/ImageMagick-6.2.5/delegates.xml",
O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or directory)
30141 open("/usr/share/ImageMagick-6.2.5/delegates.xml", O_RDONLY|O_LARGEFILE) =
-1 ENOENT (No such file or directory)
30141 open("/home/dmobrien/.magick/delegates.xml", O_RDONLY|O_LARGEFILE) = -1
ENOENT (No such file or directory)
30141 open("delegates.xml", O_RDONLY|O_LARGEFILE) = -1 ENOENT (No such file or
directory)
30141 stat64("unit.jpg", {st_mode=S_IFREG|0644, st_size=103250, ...}) = 0
30141 access("unit.jpg", F_OK)          = 0
30141 write(2, "convert: no decode delegate for "..., 60) = 60
30141 write(2, ".\n", 2)                = 2
30141 brk(0x8ef2000)                    = 0x8ef2000
30141 exit_group(0)                     = ?

$ locate delegates.xml
/usr/lib/ImageMagick-6.2.5/config/delegates.xml
Comment 3 Bracey Summers 2006-05-25 14:04:48 EDT
All image formats are broken it seems ...

FC5 box before the last yum update of ImageMagick:

> identify -list format
   Format  Module    Mode  Description
-------------------------------------------------------------------------------
        A* RAW       rw+   Raw alpha samples
      ART* ART       r--   PFS: 1st Publisher
           Format originally used on the Macintosh (MacPaint?) and later used
           for PFS: 1st Publisher clip art.  NOT the AOL ART format.
      AVI* AVI       r--   Microsoft Audio/Visual Interleaved
      AVS* AVS       rw+   AVS X image
        B* RAW       rw+   Raw blue samples
      BMP* BMP       rw-   Microsoft Windows bitmap image
     BMP2* BMP       -w-   Microsoft Windows bitmap image v2
     BMP3* BMP       -w-   Microsoft Windows bitmap image v3
        C* RAW       rw+   Raw cyan samples
    CACHE* CACHE     ---   Magick Persistent Cache image format
  CAPTION* CAPTION   r--   Image caption
      CIN* CIN       rw+   Cineon Image File
      CIP* CIP       -w-   Cisco IP phone image format
     CLIP* CLIP      -w+   Image Clip Mask
     CMYK* CMYK      rw+   Raw cyan, magenta, yellow, and black samples
    CMYKA* CMYK      rw+   Raw cyan, magenta, yellow, black, and opacity samples
      CUR* CUR       rw-   Microsoft icon
      CUT* CUT       r--   DR Halo
      DCM* DCM       r--   Digital Imaging and Communications in Medicine image
           DICOM is used by the medical community for images like X-rays.  The
           specification, "Digital Imaging and Communications in Medicine
           (DICOM)", is available at http://medical.nema.org/.  In particular,
           see part 5 which describes the image encoding (RLE, JPEG, JPEG-LS),
           and supplement 61 which adds JPEG-2000 encoding.
      DCX* PCX       rw+   ZSoft IBM PC multi-page Paintbrush
      DNG* DNG       r--   Digital Negative
      DOT  DOT       ---   Graphviz
      DPS  DPS       ---   Display Postscript Interpreter
      DPX* DPX       rw+   SMPTE 268M-2003 (DPX)
           Digital Moving Picture Exchange Bitmap, Version 2.0.
           See SMPTE 268M-2003 specification at http://www.smtpe.org

     EPDF  PDF       rw-   Encapsulated Portable Document Format
      EPI  PS        rw-   Encapsulated PostScript Interchange format
      EPS  PS        rw-   Encapsulated PostScript
     EPS2* PS2       -w-   Level II Encapsulated PostScript
     EPS3* PS3       -w+   Level III Encapsulated PostScript
     EPSF  PS        rw-   Encapsulated PostScript
     EPSI  PS        rw-   Encapsulated PostScript Interchange format
      EPT  EPT       rw-   Encapsulated PostScript with TIFF preview
     EPT2  EPT       rw-   Encapsulated PostScript Level II with TIFF preview
     EPT3  EPT       rw+   Encapsulated PostScript Level III with TIFF preview
      FAX* FAX       rw+   Group 3 FAX
           See TIFF format.  Note that FAX machines use non-square pixels which
           are 1.5 times wider than they are tall but computer displays use
           square pixels. FAX images may appear to be narrow unless they are
           explicitly resized using a resize specification of "150x100%".
     FITS* FITS      rw-   Flexible Image Transport System
  FRACTAL* PLASMA    r--   Plasma fractal image
        G* RAW       rw+   Raw green samples
       G3* FAX       rw-   Group 3 FAX
      GIF* GIF       rw+   CompuServe graphics interchange format
    GIF87* GIF       rw-   CompuServe graphics interchange format (version 87a)
 GRADIENT* GRADIENT  r--   Gradual passing from one shade to another
     GRAY* GRAY      rw+   Raw gray samples
HISTOGRAM* HISTOGRAM -w-   Histogram of the image
      HTM* HTML      -w-   Hypertext Markup Language and a client-side image map
     HTML* HTML      -w-   Hypertext Markup Language and a client-side image map
      ICB* TGA       rw+   Truevision Targa image
      ICO* ICON      rw-   Microsoft icon
     ICON* ICON      rw-   Microsoft icon
     INFO  INFO      -w+   The image format and characteristics
      JNG* PNG       rw-   JPEG Network Graphics
           See http://www.libpng.org/pub/mng/ for details about the JNG format.
           The JNG 1.0 specification is available there and at
           ftp://swrinde.nde.swri.edu/pub/mng/documents/.
     JPEG* JPEG      rw-   Joint Photographic Experts Group JFIF format (62)
      JPG* JPEG      rw-   Joint Photographic Experts Group JFIF format
        K* RAW       rw+   Raw black samples
    LABEL* LABEL     r--   Image label
        M* RAW       rw+   Raw magenta samples
      M2V  MPEG      rw+   MPEG Video Stream
      MAP* MAP       rw-   Colormap intensities and indices
      MAT* MAT       r--   MATLAB image format
    MATTE* MATTE     -w+   MATTE format
     MIFF* MIFF      rw+   Magick Image File Format
      MNG* PNG       rw+   Multiple-image Network Graphics (libpng 1.2.8)
           See http://www.libpng.org/pub/mng/ for details about the MNG format.
           The MNG 1.0 specification is available there and at
           ftp://swrinde.nde.swri.edu/pub/mng/documents/.
     MONO* MONO      rw-   Bi-level bitmap in least-significant-byte first order
      MPC* MPC       rw+   Magick Persistent Cache image format
     MPEG  MPEG      rw+   MPEG Video Stream
      MPG  MPEG      rw+   MPEG Video Stream
      MSL* MSL       rw+   Magick Scripting Language
      MTV* MTV       rw+   MTV Raytracing image format
      MVG* MVG       rw-   Magick Vector Graphics
     NULL* NULL      rw-   Constant image of uniform color
        O* RAW       rw+   Raw opacity samples
      OTB* OTB       rw-   On-the-air bitmap
      OTF* TTF       r--   Open Type font (Freetype 2.1.10)
       P7* PNM       rw+   Xv thumbnail format
      PAL* UYVY      rw-   16bit/pixel interleaved YUV
     PALM* PALM      rw+   Palm pixmap
      PAM* PNM       -w+   Common 2-dimensional bitmap format
  PATTERN* PATTERN   r--   Predefined pattern
      PBM* PNM       rw+   Portable bitmap format (black and white)
      PCD* PCD       rw-   Photo CD
     PCDS* PCD       rw-   Photo CD
      PCL* PCL       rw-   Printer Control Language
      PCT* PICT      rw-   Apple Macintosh QuickDraw/PICT
      PCX* PCX       rw-   ZSoft IBM PC Paintbrush
      PDB* PDB       rw+   Palm Database ImageViewer Format
      PDF  PDF       rw+   Portable Document Format
      PFA* TTF       r--   Postscript Type 1 font (ASCII) (Freetype 2.1.10)
      PFB* TTF       r--   Postscript Type 1 font (binary) (Freetype 2.1.10)
      PGM* PNM       rw+   Portable graymap format (gray scale)
    PICON* XPM       rw-   Personal Icon
     PICT* PICT      rw-   Apple Macintosh QuickDraw/PICT
      PIX* PIX       r--   Alias/Wavefront RLE image format
    PJPEG* JPEG      rw-   Progessive Joint Photographic Experts Group JFIF
   PLASMA* PLASMA    r--   Plasma fractal image
      PNG* PNG       rw-   Portable Network Graphics (libpng 1.2.8)
           See http://www.libpng.org/ for details about the PNG format.  The
           PNG 1.2 specification is available there and at
           ftp://swrinde.nde.swri.edu/pub/png/documents/.
    PNG24* PNG       rw-   24-bit RGB PNG, opaque only (zlib 1.2.3)
    PNG32* PNG       rw-   32-bit RGBA PNG, semitransparency OK
     PNG8* PNG       rw-   8-bit indexed PNG, binary transparency only
      PNM* PNM       rw+   Portable anymap
      PPM* PNM       rw+   Portable pixmap format (color)
  PREVIEW* PREVIEW   -w-   Show a preview an image enhancement, effect, or f/x
       PS  PS        rw+   PostScript
      PS2* PS2       -w+   Level II PostScript
      PS3* PS3       -w+   Level III PostScript
      PSD* PSD       rw+   Adobe Photoshop bitmap
     PTIF* TIFF      rw-   Pyramid encoded TIFF
      PWP* PWP       r--   Seattle Film Works
        R* RAW       rw+   Raw red samples
      RAS* SUN       rw+   SUN Rasterfile
      RGB* RGB       rw+   Raw red, green, and blue samples
     RGBA* RGB       rw+   Raw red, green, blue, and alpha samples
     RGBO* RGB       rw+   Raw red, green, blue, and opacity samples
      RLA* RLA       r--   Alias/Wavefront image
      RLE* RLE       r--   Utah Run length encoded image
      SCR* SCR       r--   ZX-Spectrum SCREEN$
      SCT* SCT       r--   Scitex HandShake
      SFW* SFW       r--   Seattle Film Works
      SGI* SGI       rw+   Irix RGB image
    SHTML* HTML      -w-   Hypertext Markup Language and a client-side image map
  STEGANO* STEGANO   r--   Steganographic image
      SUN* SUN       rw+   SUN Rasterfile
      SVG* SVG       rw+   Scalable Vector Graphics (XML 2.6.23)
     SVGZ* SVG       rw+   Compressed Scalable Vector Graphics (XML 2.6.23)
     TEXT* TXT       rw+   Text
      TGA* TGA       rw+   Truevision Targa image
      TIF* TIFF      rw+   Tagged Image File Format (42)
     TIFF* TIFF      rw+   Tagged Image File Format (42)
     TILE* TILE      r--   Tile image with a texture
      TIM* TIM       r--   PSX TIM
      TTC* TTF       r--   TrueType font collection (Freetype 2.1.10)
      TTF* TTF       r--   TrueType font (Freetype 2.1.10)
      TXT* TXT       rw+   Text
      UIL* UIL       -w-   X-Motif UIL table
     UYVY* UYVY      rw-   16bit/pixel interleaved YUV
      VDA* TGA       rw+   Truevision Targa image
    VICAR* VICAR     rw-   VICAR rasterfile format
      VID* VID       rw+   Visual Image Directory
     VIFF* VIFF      rw+   Khoros Visualization image
      VST* TGA       rw+   Truevision Targa image
     WBMP* WBMP      rw-   Wireless Bitmap (level 0) image
      WMF* WMF       r--   Windows Meta File
      WMZ* WMZ       r--   Compressed Windows Meta File
      WPG* WPG       r--   Word Perfect Graphics
        X* X         rw+   X Image
      XBM* XBM       rw-   X Windows system bitmap (black and white)
       XC* XC        r--   Constant image uniform color
      XCF* XCF       r--   GIMP image
      XPM* XPM       rw-   X Windows system pixmap (color)
       XV* VIFF      rw+   Khoros Visualization image
      XWD* XWD       rw-   X Windows system window dump (color)
        Y* RAW       rw+   Raw yellow samples
    YCbCr* YCbCr     rw+   Raw Y, Cb, and Cr samples
   YCbCrA* YCbCr     rw+   Raw Y, Cb, Cr, and opacity samples
      YUV* YUV       rw-   CCIR 601 4:1:1 or 4:2:2

* native blob support


FC5 box after the last yum update of ImageMagick:

> identify -list format
   Format  Module    Mode  Description
-------------------------------------------------------------------------------

* native blob support

Comment 4 Fedora Update System 2006-05-25 15:28:57 EDT
ImageMagick-6.2.5.4-4.2.1.fc5.3 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Scott Baker 2006-05-25 16:57:21 EDT
I just installed the updated ImageMagick via yum and "convert" works now. I 
haven't tested all the other tools, but I'd say the problem is fixed.
Comment 6 Mamoru TASAKA 2006-05-26 00:59:01 EDT
This problem was caused by bug 185237.

Now ImageMagick-6.2.5.4-4.2.1.fc5.3 seems to work well.

Note You need to log in before you can comment on or make changes to this bug.