Bug 1931384 - No audio on Fedora 34 after pipewire 0.3.22-4 has been installed.
Summary: No audio on Fedora 34 after pipewire 0.3.22-4 has been installed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pipewire
Version: 34
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Wim Taymans
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeExcepti...
Depends On:
Blocks: F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-02-22 10:29 UTC by Lukas Ruzicka
Modified: 2021-05-03 18:55 UTC (History)
14 users (show)

Fixed In Version: pipewire-0.3.26-4.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-02 02:03:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Ruzicka 2021-02-22 10:29:46 UTC
Description of problem:

Updating to pipewire 0.3.22-4 caused my Fedora 34 desktop to fail on playing audio through PipeWire. Everything is affected - GStreamer application, JACK applications, PulseAudio. The only thing that is still working is ALSA when operated via aplay commands.

It is weird because the services are running but applications cannot connect to it.

Version-Release number of selected component (if applicable):

The problem started with pipewire-0.3.22-4 and still persists on pipewire-0.3.22-5

How reproducible:

Always

Steps to Reproduce:
1. Upgrade to the mentioned pipewire version.
2. Restart the computer.

Actual results:

No audio except ALSA is now available on my Fedora 34.

Expected results:

Audio has no issues and works for all parts (jack, pulse, midi, ...)

Additional info:

[lruzicka@vseved ~]$ systemctl --user status pipewire
=======================================================
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Mon 2021-02-22 11:06:20 CET; 16min ago
TriggeredBy: ● pipewire.socket
   Main PID: 2483 (pipewire)
      Tasks: 2 (limit: 38441)
     Memory: 692.0K
        CPU: 4ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2483 /usr/bin/pipewire

úno 22 11:06:20 vseved systemd[1935]: Started Multimedia Service.
========================================================

[lruzicka@vseved ~]$ systemctl --user status pipewire-pulse
=============================================================
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: disabled)
     Active: active (running) since Mon 2021-02-22 11:06:19 CET; 18min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2237 (pipewire-pulse)
      Tasks: 2 (limit: 38441)
     Memory: 1.1M
        CPU: 236ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.service
             └─2237 /usr/bin/pipewire-pulse

úno 22 11:24:15 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:24:15 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3c58f0: [GNOME Shell Volume Control] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host i>
úno 22 11:24:20 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:24:20 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3c58f0: [GNOME Shell Volume Control] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host i>
úno 22 11:24:20 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:24:20 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3c58f0: [GNOME Volume Control Media Keys] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (H>
úno 22 11:24:25 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:24:25 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3c5bd0: [GNOME Volume Control Media Keys] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (H>
úno 22 11:24:25 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:24:25 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3c58f0: [GNOME Shell Volume Control] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host i>
=========================================================================

[lruzicka@vseved ~]$ pw-dump 0
can't connect: Host is down

[lruzicka@vseved ~]$ pactl info
Connection failure: Connection refused

[lruzicka@vseved ~]$ pactl list
Connection failure: Connection refused

journalctl -b | grep pipewire:
=============================================
úno 22 11:06:03 vseved rtkit-daemon[1132]: Successfully made thread 1616 of process 1616 (/usr/bin/pipewire-pulse) owned by '42' high priority at nice level -11.
úno 22 11:06:03 vseved rtkit-daemon[1132]: Successfully made thread 1617 of process 1616 (/usr/bin/pipewire-pulse) owned by '42' RT at priority 20.
úno 22 11:06:19 vseved rtkit-daemon[1132]: Successfully made thread 2237 of process 2237 (/usr/bin/pipewire-pulse) owned by '1000' high priority at nice level -11.
úno 22 11:06:19 vseved rtkit-daemon[1132]: Successfully made thread 2238 of process 2237 (/usr/bin/pipewire-pulse) owned by '1000' RT at priority 20.
úno 22 11:06:30 vseved systemd[1414]: pipewire.service: Succeeded.
úno 22 11:06:30 vseved systemd[1414]: pipewire-pulse.service: Succeeded.
úno 22 11:06:30 vseved systemd[1414]: pipewire-pulse.socket: Succeeded.
úno 22 11:06:30 vseved systemd[1414]: pipewire.socket: Succeeded.
úno 22 11:07:30 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:07:30 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3f9dd0: [GNOME Volume Control Media Keys] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host is down)
úno 22 11:07:30 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:07:30 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3fa930: [GNOME Shell Volume Control] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host is down)
úno 22 11:07:35 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:07:35 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3f1900: [GNOME Shell Volume Control] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host is down)
úno 22 11:07:35 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
úno 22 11:07:35 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3f1a70: [GNOME Volume Control Media Keys] ERROR command:9 (SET_CLIENT_NAME) tag:1 error:6 (Host is down)
úno 22 11:07:40 vseved pipewire-pulse[2237]: pulse-server 0x55b16c3cd8d0: failed to connect client: Host is down
..... (many such messages)

Comment 1 Fedora Blocker Bugs Application 2021-02-22 11:07:23 UTC
Proposed as a Blocker for 34-beta by Fedora user lruzicka using the blocker tracking app because:

 This violates the Working sound criteria.

The installed system must be able to play back sound with gstreamer-based applications.

No audio on the system.

Comment 2 Wim Taymans 2021-02-22 11:11:01 UTC
Check that you have updated the config files to the new keys.

Comment 3 Lukas Ruzicka 2021-02-22 11:17:57 UTC
Oh, yeah. This helped indeed. Thank you very much.

Comment 4 Lukas Ruzicka 2021-02-22 11:20:40 UTC
However, should updating to new files not be automated? I do not think that moving some old settings to the pipewire.conf.<something> and adopting the new settings would be actually worse than leaving the new settings aside and the system without audio.

Comment 5 Wim Taymans 2021-02-22 11:36:37 UTC
> However, should updating to new files not be automated? I do not think that moving some old settings to the pipewire.conf.<something> and adopting the new settings would be actually worse than leaving the new settings aside and the system without audio.

It has been discussed. In general, this is a temporary problem, with this incompatible change active now, future config files will be compatible
and not cause problems. It also only happens when you manually changed something. 

If is recommended to not overwrite config files but maybe for these few version, overriding is better until things have settled down?

Comment 6 Lukas Ruzicka 2021-02-22 18:11:34 UTC
Today at the Blocker Review Meeting, we agreed that maximum should be done to keep audio working during upgrades and updates:

#agreed 1931384 - RejectedBlocker (Beta) AcceptedFreezeException (Beta) - as the affected package is not installed in any default F32 or F33 install, this does not violate the release criteria, but since it is known to be pulled in by popular third-party packages, we feel it's worth an FE to improve the upgrade situation during freeze if possible

Comment 7 Geoffrey Marr 2021-02-22 20:05:49 UTC
Discussed during the 2021-02-22 blocker review meeting: [0]

The decision to classify this bug as a "RejectedBlocker (Beta)" and an "AcceptedFreezeException (Beta)" was made as the affected package is not installed in any default F32 or F33 install, so this does not violate the release criteria, but since it is known to be pulled in by popular third-party packages, we feel it's worth an FE to improve the upgrade situation during freeze if possible.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2021-02-22/f34-blocker-review.2021-02-22-17.07.txt

Comment 8 František Zatloukal 2021-02-22 22:59:58 UTC
(In reply to Wim Taymans from comment #5)
> > However, should updating to new files not be automated? I do not think that moving some old settings to the pipewire.conf.<something> and adopting the new settings would be actually worse than leaving the new settings aside and the system without audio.
> 
> It has been discussed. In general, this is a temporary problem, with this
> incompatible change active now, future config files will be compatible
> and not cause problems. It also only happens when you manually changed
> something. 
> 
> If is recommended to not overwrite config files but maybe for these few
> version, overriding is better until things have settled down?

Just to note that there are some high profile packages out in rpmfusion (eg. steam) pulling in pipewire on F33 already. That would mean that people having installed steam (and so pipewire) would loose audio after upgrade to F34, if I understand this right.

IMO, either having some migration code or overwriting the config file is lesser evil.

Comment 9 Wim Taymans 2021-02-24 10:15:18 UTC
> Just to note that there are some high profile packages out in rpmfusion (eg. steam) pulling in pipewire on F33 already. That would mean that people having installed steam (and so pipewire) would loose audio after upgrade to F34, if I understand this right.

Only if they have made changes to the configuration files, otherwise the old config files will be overwritten with the new files and
all will be fine.

Comment 10 Lukas Ruzicka 2021-02-26 09:42:04 UTC
I still believe that even if they had changed their configs, they do not deserve to lose the audio and that rewriting their configuration files is "lesser evil". 

My 2 cents.

Comment 11 André 2021-03-05 06:45:57 UTC
(In reply to Wim Taymans from comment #2)
> Check that you have updated the config files to the new keys.

I am having the same problem, what's the procedure to update the keys?

Comment 12 André 2021-03-05 06:49:27 UTC
(In reply to André from comment #11)
> (In reply to Wim Taymans from comment #2)
> > Check that you have updated the config files to the new keys.
> 
> I am having the same problem, what's the procedure to update the keys?

Also, I did not change the config file, this is a fresh install of pipewire on my fedora 33.

Comment 13 Lukas Ruzicka 2021-03-11 13:01:36 UTC
(In reply to André from comment #11)
> (In reply to Wim Taymans from comment #2)
> > Check that you have updated the config files to the new keys.
> 
> I am having the same problem, what's the procedure to update the keys?

I guess, the best option is to delete the config files and reinstall pipewire.

Comment 14 Brian 'redbeard' Harrington 2021-04-16 17:35:42 UTC
I have a clarifying question. The discussion of "deleting" configuration files is _really_ to say:

 "Rename the configuration file with a '.rpmsave' extension so that the user can fix things if the automation breaks"

correct?

Comment 15 Lukas Ruzicka 2021-04-19 10:42:35 UTC
(In reply to Brian 'redbeard' Harrington from comment #14)
> I have a clarifying question. The discussion of "deleting" configuration
> files is _really_ to say:
> 
>  "Rename the configuration file with a '.rpmsave' extension so that the user
> can fix things if the automation breaks"
> 
> correct?

Yeah,
you can do this, too. But the old config files prevent pipewire service from starting, so you can only use them if you decide to go back to the previous version.

So to make things clear (this fixed it for me):
- Move the pipewire.conf to pipewire.conf.rpmsave.
- Restart the service -> a new pipewire.conf should be created with correct keys and stuff should be working again.

Comment 16 Luc de Louw 2021-04-28 07:38:34 UTC
Hi,

I had the same problem after upgrading from F33 to F34. The solution for me was:

rm -rf /etc/pipewire
dnf reinstall pipewire-alsa.x86_64 pipewire-gstreamer.x86_64 pipewire-pulseaudio.x86_64 pipewire
systemctl --user restart pipewire pipewire-pulse

Comment 17 Fedora Update System 2021-04-29 07:57:11 UTC
FEDORA-2021-03756cf274 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-03756cf274

Comment 18 Fedora Update System 2021-04-29 17:10:52 UTC
FEDORA-2021-03756cf274 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-03756cf274`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-03756cf274

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Torbjorn Jansson 2021-05-01 18:00:49 UTC
A question, i am seeing crashes in virt-manger whenever i have a running vm and switches over to the console display.
when this happens i end up with this in dmesg:

virt-manager[41541]: segfault at 10 ip 00007f2a30d7d84e sp 00007fffa7b70c90 error 4 in libpipewire-0.3.so.0.326.0[7f2a30d71000+4d000]

note the libpipewire part.
this crash started after upgrade to fedora 34.

is this related to this bug or something different?

Comment 20 Fedora Update System 2021-05-02 02:03:05 UTC
FEDORA-2021-03756cf274 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Jeff Buhrt 2021-05-02 22:02:02 UTC
I just upgraded from Fedora 33 to 34 on a laptop. I have no audio output devices now. I have reinstalled and rebooted/logged out multiple times. I cleared /etc/pipewire each time before running "sudo dnf reinstall pipewire"


None will work: internal speakers, ALSA (ALM0905 USB external sound (worked great on Fedora 33), nor a USB headet + microphone. 

This isn't yet fixed or hasn't been pushed to the repos.

Comment 22 Jeff Buhrt 2021-05-02 22:15:44 UTC
Really weird... I followed  Luc de Louw's suggestion of also reinstalling, then restarting:
dnf reinstall pipewire-alsa.x86_64 pipewire-gstreamer.x86_64 pipewire-pulseaudio.x86_64 pipewire
systemctl --user restart pipewire pipewire-pulse

I see the USB device and internal. Sound stops if I change volume down one notch and back up one notch. If I then restart using "systemctl --user restart pipewire pipewire-pulse" sound on the internal speakers and USB work until the volume is changed. I can change the volume on the USB headset up and down and don't lose sound. Fedora 34 may not be quite read for prime time yet.

May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Stopping Multimedia Service...
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Stopping PipeWire PulseAudio...
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Deactivated successfully.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Stopped PipeWire PulseAudio.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Consumed 1.725s CPU time.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: pipewire.service: Deactivated successfully.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Stopped Multimedia Service.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: pipewire.service: Consumed 1.801s CPU time.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Started Multimedia Service.
May 02 18:11:18 jtosh.aftinc.net systemd[7110]: Started PipeWire PulseAudio.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17420 of process 17420 (/usr/bin/pipewire) owned by '1001' high priority at nice level -11.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 2 threads of 2 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17421 of process 17421 (/usr/bin/pipewire-pulse) owned by '1001' high priority at nice level -11.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17430 of process 17430 (/usr/bin/pipewire-media-session) owned by '1001' high priority at nice level -11.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17425 of process 17420 (/usr/bin/pipewire) owned by '1001' RT at priority 20.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17426 of process 17421 (/usr/bin/pipewire-pulse) owned by '1001' RT at priority 20.
May 02 18:11:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 6 threads of 4 processes of 1 users.
May 02 18:11:19 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17432 of process 17430 (/usr/bin/pipewire-media-session) owned by '1001' RT at priority 20.
May 02 18:11:19 jtosh.aftinc.net rtkit-daemon[844]: Supervising 7 threads of 4 processes of 1 users.
May 02 18:11:19 jtosh.aftinc.net pipewire-media-session[17430]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:11:19 jtosh.aftinc.net pipewire-media-session[17430]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:11:19 jtosh.aftinc.net pipewire-media-session[17430]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:11:19 jtosh.aftinc.net pipewire-media-session[17430]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:11:24 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default sink
May 02 18:11:24 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default source
May 02 18:11:24 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 28, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:11:24 jtosh.aftinc.net gnome-control-c[17363]: gvc_mixer_ui_device_get_id: assertion 'GVC_IS_MIXER_UI_DEVICE (device)' failed
May 02 18:11:24 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 30, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:11:44 jtosh.aftinc.net pipewire-media-session[17430]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Stopping Multimedia Service...
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Stopping PipeWire PulseAudio...
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Deactivated successfully.
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Stopped PipeWire PulseAudio.
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: pipewire.service: Deactivated successfully.
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Stopped Multimedia Service.
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Started Multimedia Service.
May 02 18:12:00 jtosh.aftinc.net systemd[7110]: Started PipeWire PulseAudio.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17454 of process 17454 (/usr/bin/pipewire) owned by '1001' high priority at nice level -11.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 2 threads of 2 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17455 of process 17455 (/usr/bin/pipewire-pulse) owned by '1001' high priority at nice level -11.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17464 of process 17464 (/usr/bin/pipewire-media-session) owned by '1001' high priority at nice level -11.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17459 of process 17454 (/usr/bin/pipewire) owned by '1001' RT at priority 20.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17460 of process 17455 (/usr/bin/pipewire-pulse) owned by '1001' RT at priority 20.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 6 threads of 4 processes of 1 users.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17466 of process 17464 (/usr/bin/pipewire-media-session) owned by '1001' RT at priority 20.
May 02 18:12:00 jtosh.aftinc.net rtkit-daemon[844]: Supervising 7 threads of 4 processes of 1 users.
May 02 18:12:01 jtosh.aftinc.net pipewire-media-session[17464]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:12:01 jtosh.aftinc.net pipewire-media-session[17464]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:12:01 jtosh.aftinc.net pipewire-media-session[17464]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:12:01 jtosh.aftinc.net pipewire-media-session[17464]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:12:05 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default sink
May 02 18:12:05 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default source
May 02 18:12:05 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 55, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:05 jtosh.aftinc.net gnome-control-c[17363]: gvc_mixer_ui_device_get_id: assertion 'GVC_IS_MIXER_UI_DEVICE (device)' failed
May 02 18:12:05 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 57, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:05 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 131, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:05 jtosh.aftinc.net gsd-media-keys[7656]: gvc_mixer_ui_device_get_id: assertion 'GVC_IS_MIXER_UI_DEVICE (device)' failed
May 02 18:12:05 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 133, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:05 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 131, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:05 jtosh.aftinc.net gnome-shell[7283]: gvc_mixer_ui_device_get_id: assertion 'GVC_IS_MIXER_UI_DEVICE (device)' failed
May 02 18:12:05 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 133, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:12:25 jtosh.aftinc.net pipewire-media-session[17464]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Stopping Multimedia Service...
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Stopping PipeWire PulseAudio...
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Deactivated successfully.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Stopped PipeWire PulseAudio.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Consumed 1.109s CPU time.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: pipewire.service: Deactivated successfully.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Stopped Multimedia Service.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: pipewire.service: Consumed 1.482s CPU time.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Started Multimedia Service.
May 02 18:13:18 jtosh.aftinc.net systemd[7110]: Started PipeWire PulseAudio.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17486 of process 17486 (/usr/bin/pipewire) owned by '1001' high priority at nice level -11.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 2 threads of 2 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17487 of process 17487 (/usr/bin/pipewire-pulse) owned by '1001' high priority at nice level -11.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17497 of process 17497 (/usr/bin/pipewire-media-session) owned by '1001' high priority at nice level -11.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17491 of process 17486 (/usr/bin/pipewire) owned by '1001' RT at priority 20.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17492 of process 17487 (/usr/bin/pipewire-pulse) owned by '1001' RT at priority 20.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 6 threads of 4 processes of 1 users.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17498 of process 17497 (/usr/bin/pipewire-media-session) owned by '1001' RT at priority 20.
May 02 18:13:18 jtosh.aftinc.net rtkit-daemon[844]: Supervising 7 threads of 4 processes of 1 users.
May 02 18:13:19 jtosh.aftinc.net pipewire-media-session[17497]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:19 jtosh.aftinc.net pipewire-media-session[17497]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:19 jtosh.aftinc.net pipewire-media-session[17497]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:19 jtosh.aftinc.net pipewire-media-session[17497]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:23 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default sink
May 02 18:13:23 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default source
May 02 18:13:23 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 73, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:23 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 75, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:23 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 149, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:23 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 151, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:23 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 149, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:23 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 151, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Stopping Multimedia Service...
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Stopping PipeWire PulseAudio...
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: pipewire-pulse.service: Deactivated successfully.
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Stopped PipeWire PulseAudio.
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: pipewire.service: Deactivated successfully.
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Stopped Multimedia Service.
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Started Multimedia Service.
May 02 18:13:28 jtosh.aftinc.net systemd[7110]: Started PipeWire PulseAudio.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17509 of process 17509 (/usr/bin/pipewire) owned by '1001' high priority at nice level -11.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 2 threads of 2 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17510 of process 17510 (/usr/bin/pipewire-pulse) owned by '1001' high priority at nice level -11.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 3 threads of 3 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17519 of process 17519 (/usr/bin/pipewire-media-session) owned by '1001' high priority at nice level -11.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 4 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17514 of process 17509 (/usr/bin/pipewire) owned by '1001' RT at priority 20.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 5 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17515 of process 17510 (/usr/bin/pipewire-pulse) owned by '1001' RT at priority 20.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 6 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Successfully made thread 17521 of process 17519 (/usr/bin/pipewire-media-session) owned by '1001' RT at priority 20.
May 02 18:13:28 jtosh.aftinc.net rtkit-daemon[844]: Supervising 7 threads of 4 processes of 1 users.
May 02 18:13:28 jtosh.aftinc.net pipewire-media-session[17519]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:28 jtosh.aftinc.net pipewire-media-session[17519]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:28 jtosh.aftinc.net pipewire-media-session[17519]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:28 jtosh.aftinc.net pipewire-media-session[17519]: The decibel volume range for element 'Headphone' (-9999999 dB - -6 dB) has negative maximum. Disabling the decibel range.
May 02 18:13:33 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default sink
May 02 18:13:33 jtosh.aftinc.net gsd-media-keys[7656]: Unable to get default source
May 02 18:13:33 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 79, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:33 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 155, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:33 jtosh.aftinc.net gnome-control-c[17363]: Sync_devices: Failed to match stream id: 81, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:33 jtosh.aftinc.net gsd-media-keys[7656]: Sync_devices: Failed to match stream id: 157, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:33 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 155, description: 'Speakers', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:33 jtosh.aftinc.net gnome-shell[7283]: Sync_devices: Failed to match stream id: 157, description: 'Internal Microphone', origin: 'Built-in Audio Analog Stereo'
May 02 18:13:53 jtosh.aftinc.net pipewire-media-session[17519]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: new full-speed USB device number 4 using ehci-pci
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: New USB device found, idVendor=0d8c, idProduct=0012, bcdDevice= 1.00
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: Product: USB Headset
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: Manufacturer: C-Media Electronics Inc.
May 02 18:13:56 jtosh.aftinc.net kernel: usb 1-1.1: SerialNumber: 202006
May 02 18:13:56 jtosh.aftinc.net kernel: input: C-Media Electronics Inc. USB Headset as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.3/0003:0D8C:0012.0007/input/input27
May 02 18:13:56 jtosh.aftinc.net kernel: hid-generic 0003:0D8C:0012.0007: input,hidraw5: USB HID v1.00 Device [C-Media Electronics Inc. USB Headset] on usb-0000:00:1a.0-1.1/input3
May 02 18:13:56 jtosh.aftinc.net mtp-probe[17535]: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1"
May 02 18:13:56 jtosh.aftinc.net mtp-probe[17535]: bus: 1, device: 4 was not an MTP device
May 02 18:13:56 jtosh.aftinc.net mtp-probe[17546]: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1"
May 02 18:13:56 jtosh.aftinc.net mtp-probe[17546]: bus: 1, device: 4 was not an MTP device

Comment 23 Torbjorn Jansson 2021-05-03 06:40:44 UTC
(In reply to Torbjorn Jansson from comment #19)
> A question, i am seeing crashes in virt-manger whenever i have a running vm
> and switches over to the console display.
> when this happens i end up with this in dmesg:
> 
> virt-manager[41541]: segfault at 10 ip 00007f2a30d7d84e sp 00007fffa7b70c90
> error 4 in libpipewire-0.3.so.0.326.0[7f2a30d71000+4d000]
> 
> note the libpipewire part.
> this crash started after upgrade to fedora 34.
> 
> is this related to this bug or something different?

FYI this crash disappeared after updating to the new version of pipewire.

Comment 24 Adam Williamson 2021-05-03 18:55:32 UTC
Jeff, Torbjorn: your issues sound (no pun intended...) different from this bug. Please file separately (well, Torbjorn, I guess if yours is fixed now, no need to). Jeff, your case looks like pipewire has some trouble with your specific device, so details on what the device is and perhaps the lsusb output for it would be useful. Thanks!


Note You need to log in before you can comment on or make changes to this bug.