Bug 19315 - alevt generic /usr/X11 bug.
Summary: alevt generic /usr/X11 bug.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: alevt (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 12:57 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 12:58:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-18 12:57:58 UTC
alevt's SPEC creates a directory at /usr/X11 to install it's
mini-alevt.xpm:
(line) 35 "install -m644 contrib/mini-alevt.xpm
$RPM_BUILD_ROOT/usr/X11/include/X11/pixmaps"
"%files
%defattr(-,root,root)
%doc CHANGELOG COPYRIGHT README alevt.lsm.in
%attr(0755,root,root) /usr/X11R6/bin/alevt
%attr(0755,root,root) /usr/bin/alevt-date
%attr(0644,root,root) /usr/man/man1/alevt.1x
%attr(0644,root,root) /usr/man/man1/alevt-date.1
(line) 56%attr(0644,root,root) /usr/X11/include/X11/pixmaps/mini-alevt.xpm"

/usr/X11 as I understand is a dirctory once used prior to X11R6 but here
the way the writer intended is not to give backward compatibilty as in
aout-libs (which creates /usr/X11 as a symbolic link to /usr/X11R6) but it
appears as if whoever built this simply got his directory wrong and may
have intended to install this in /usr/X11R6/include....  .
This causes a scenerio in which if I'll install alevt and then aout-libs
I'll get this :

# rpm -i /blobs/real/alevt-1.4.9-2.i386.rpm
# rpm -i /blobs/real/aout-libs-1.4-14.i386.rpm
unpacking of archive failed on file /usr/X11: cpio: unlink 

Because the /usr/X11 is an existing directory and canont be used as the
link to /usr/X11R6.
All you need to do is check if the link exists in alevt spec or change that
pixmap's path.
regards-

Lior Kesos
Aduva Research Team.

Comment 1 Karsten Hopp 2000-10-23 11:48:49 UTC
Fixed in next version, thanks for the bugreport


Note You need to log in before you can comment on or make changes to this bug.