Bug 193186 - "Anaconda" does not install the video driver used in "xorg.conf"
"Anaconda" does not install the video driver used in "xorg.conf"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 17:38 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 21:32:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-05-25 17:38:26 EDT
Description of problem:
After a fresh install of Fedora Core rawhide, the "X" server is
unusable. I turns out that only the "VESA" driver package is
installed whereas the driver in "xorg.conf" is correctly set to
"savage" on the affected "IBM ThinkPad T23". Consequently, the
specified driver module cannot be loaded.

Version-Release number of selected component (if applicable):
anaconda-11.1.0.20-1

How reproducible:
Always.

Steps to Reproduce:
1. Install FC rawhide.
2. Reboot the system.
  
Actual results:
Screen corrupted, after entering "ctrl-alt-bckspc", a console
message is issued according to which the requested driver module
was not found.

Expected results:
System should boot into graphical mode.

Additional info:
After installing the missing driver package by hand, everything
works as expected (setting the driver entry in "xorg.conf" to
"vesa" would of course have also worked). The issue seems to be
related to the recent upgrade of "X" to release 7.1. Prior to this,
all driver packages were installed by default, so the right one was
always present. After dropping this requirement, one has apparently
forgotten to tell "anaconda" that it has to install the driver
package corresponding to the driver entry in "xorg.conf".
Comment 1 Jeremy Katz 2006-05-25 21:32:33 EDT
Added drivers to comps 

Note You need to log in before you can comment on or make changes to this bug.