Bug 193188 - tcp_wrappers should have a -devel subpackage
tcp_wrappers should have a -devel subpackage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcp_wrappers (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-05-25 18:04 EDT by Jeremy Katz
Modified: 2013-01-09 22:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 17:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcp_wrappers split up patch (2.02 KB, patch)
2006-09-22 10:49 EDT, Thomas Woerner
no flags Details | Diff

  None (edit)
Description Jeremy Katz 2006-05-25 18:04:40 EDT
tcp_wrappers includes include files and libraries intended for developing
against and should thus have a -devel subpackage
Comment 1 Matthias Clasen 2006-09-21 23:14:31 EDT
Hardly an fc6 blocker though, I think.
Comment 2 Jeremy Katz 2006-09-21 23:18:28 EDT
Actually, it is kind of important as that's the only way we can correctly
include the shared libs as multilib.
Comment 3 Thomas Woerner 2006-09-22 10:35:20 EDT
There are no file conflicts between current tcp_wrappers multilib packages at all.

I'd like to split tcp_wrappers up in three packages: tcp_wrappers,
tcp_wrappers-libs and tcp_wrappers-devel. But I think it is too late for FC-6
for this change.
Comment 4 Thomas Woerner 2006-09-22 10:49:21 EDT
Created attachment 136945 [details]
tcp_wrappers split up patch

This patch splits tcp_wrappers up in three packages: tcp_wrappers,
tcp_wrappers-libs and tcp_wrappers-devel.

This change would require a rebuild of all packages, which depend on
tcp_wrappers with an additional "BuildRequies: tcp_wrappers-devel".

Note You need to log in before you can comment on or make changes to this bug.