Bug 193189 - should have libpcap-devel
should have libpcap-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcpdump (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
: Reopened
Depends On:
Blocks: FC6Blocker 195764
  Show dependency treegraph
 
Reported: 2006-05-25 18:05 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-04 14:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-05-25 18:05:35 EDT
As libpcap is intended for developing against, there should be a -devel subpackage
Comment 1 Martin Stransky 2006-05-30 14:19:40 EDT
modified in rawhide...
Comment 2 Ville Skyttä 2006-06-03 14:38:34 EDT
There is one issue with the implementation as of 14:3.9.4-6: libpcap.so is in
the main libpcap package, and libpcap-devel does not have a dependency on libpcap.

The result is that packages that have "BuildRequires: libpcap-devel" will not
have libpcap pulled in in various build roots, and because the *.so symlink is
in the main package and thus not available, will become statically linked with
libpcap.a, which is unexpected.

Fix: move the libpcap.so symlink to libpcap-devel and/or add a dependency on
libpcap to libpcap-devel.  Additionally, is there a need to ship the static lib
in the first place?

One more thing while at it: libpcap-devel ships the empty /usr/include/net
directory which seems odd, perhaps that can be dropped?
Comment 3 Dennis Gilmore 2006-06-03 15:14:29 EDT
going by Fedora Extras policy,  which new Core packages must use.  you need to 
put the .so files in the devel packages  and you need to have the 
libpcap-devel package Require a versioned libpcap package
Comment 4 Jeremy Katz 2006-06-04 14:02:16 EDT
Agreed -- fixed these up in CVS

Note You need to log in before you can comment on or make changes to this bug.