Bug 1931903 - operator registry has high memory usage in 4.7... cleanup row closes
Summary: operator registry has high memory usage in 4.7... cleanup row closes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.7
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.7.z
Assignee: Evan Cordell
QA Contact: xzha
URL:
Whiteboard:
Depends On: 1921763
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-23 14:27 UTC by OpenShift BugZilla Robot
Modified: 2021-03-16 08:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-16 08:42:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-registry pull 597 0 None open [release-4.7] Bug 1931903: add missing closes 2021-02-25 03:42:03 UTC
Red Hat Product Errata RHBA-2021:0749 0 None None None 2021-03-16 08:43:10 UTC

Description OpenShift BugZilla Robot 2021-02-23 14:27:42 UTC
+++ This bug was initially created as a clone of Bug #1921763 +++

Description of problem:
operator registry appears to be growing in memory size. This ticket has an attached PR to cleanup row closes.

https://github.com/operator-framework/operator-registry/pull/570

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 xzha 2021-03-04 05:09:37 UTC
verify:

[root@preserve-olm-env testcases]# oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.7.0-0.nightly-2021-03-04-004412   True        False         129m    Cluster version is 4.7.0-0.nightly-2021-03-04-004412
[root@preserve-olm-env testcases]# oc adm release info registry.ci.openshift.org/ocp/release:4.7.0-0.nightly-2021-03-04-004412 --commits|grep operator-registry
  operator-registry                              https://github.com/operator-framework/operator-registry                     6183dbb3567397e759f25752011834f86f47a3ea
[root@preserve-olm-env testcases]# 


step1. install Elasticsearch-operators 

[root@preserve-olm-env testcases]# oc get pod -A | grep -i Elastic
openshift-operators                                elastic-operator-5c59577d96-plgfk                                    1/1     Running            0          85m
[root@preserve-olm-env testcases]# 



step2. monitor memory usage

https://user-images.githubusercontent.com/77608951/109914197-6f834f00-7cea-11eb-92df-63237a705645.png
https://user-images.githubusercontent.com/77608951/109914369-c6892400-7cea-11eb-9b35-5b70f5983a32.png

there is no memory leak

verified.

Comment 6 errata-xmlrpc 2021-03-16 08:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.2 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0749


Note You need to log in before you can comment on or make changes to this bug.