Bug 1931951 - systemd-udev-248~rc1-2.fc35 no longer provides /usr/bin/kernel-install
Summary: systemd-udev-248~rc1-2.fc35 no longer provides /usr/bin/kernel-install
Keywords:
Status: CLOSED DUPLICATE of bug 1931957
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-23 16:15 UTC by Kevin Fenzi
Modified: 2021-02-23 16:28 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-23 16:28:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Fenzi 2021-02-23 16:15:09 UTC
➜  ~ rpm -qf /usr/bin/kernel-install                                     
error: file /usr/bin/kernel-install: No such file or directory
➜  ~ rpm -qli systemd-udev | grep kernel-install                     
/usr/share/bash-completion/completions/kernel-install
/usr/share/man/man8/kernel-install.8.gz
/usr/share/systemd/kernel-install
/usr/share/zsh/site-functions/_kernel-install
➜  ~ sudo dnf repoquery -l systemd-udev-247.3-3.fc35.x86_64 | grep kernel
DNSSEC extension: Testing already imported keys for their validity.
Last metadata expiration check: 0:45:37 ago on Tue 23 Feb 2021 07:27:36 AM PST.
/etc/kernel
/etc/kernel/install.d
/usr/bin/kernel-install
/usr/lib/kernel
/usr/lib/kernel/install.d
/usr/lib/kernel/install.d/00-entry-directory.install
/usr/lib/kernel/install.d/20-grubby.install
/usr/lib/kernel/install.d/50-depmod.install
/usr/lib/kernel/install.d/90-loaderentry.install
/usr/lib/systemd/system/sockets.target.wants/systemd-udevd-kernel.socket
/usr/lib/systemd/system/systemd-udevd-kernel.socket
/usr/share/bash-completion/completions/kernel-install
/usr/share/man/man8/kernel-install.8.gz
/usr/share/man/man8/systemd-udevd-kernel.socket.8.gz
/usr/share/zsh/site-functions/_kernel-install
➜  ~ rpm -q systemd-udev
systemd-udev-248~rc1-2.fc35.x86_64

This is dooming both f34 and rawhide composes. ;(

Comment 1 Adam Williamson 2021-02-23 16:28:27 UTC
Duping against mine even though mine's later as I did all the blocker bureaucracy there.

*** This bug has been marked as a duplicate of bug 1931957 ***


Note You need to log in before you can comment on or make changes to this bug.