Bug 19320 - Install fails on RH7
Install fails on RH7
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 11:01 EDT by Mike Davis
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 09:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Davis 2000-10-18 11:01:43 EDT
Text of error:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line 
427, in getScreen
    self.todo.getCompsList()
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in 
readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in 
readCompsFile
    raise TypeError, "comp file version 3 or 4 expected"
TypeError: comp file version 3 or 4 expected

Local variables in innermost frame:
arch2: i686


-----

Updates applied with no change:

update-disk-20001009.img
anaconda-vfat-label-fix.img


Installer crashes every time after Authentication Configuration.

PC stats:

Pentium III 600, 128M, 13gig, Matrox Video

Windows NT pre-installed, 2008 meg C: FAT partition, 11000 meg D: NTFS 
partition.

Attempting to put a 500meg /boot partition, and a 12000 meg / partition 
with a 380 meg Swap partition.
Comment 1 Brock Organ 2000-10-18 15:25:17 EDT
what is your install source ...? a CDROM ...? network based ...? Hard drive ...?

I ask because the installer is right at the point of reading the package
information, but the error indicates that the file containing that information
(comps) is not in a proper format ... can you verify your install source ...?

we've seen similar problems with bad ftp downloads or other issues with copying
the source media ...
Comment 2 Mike Davis 2000-10-18 15:44:35 EDT
The install source is boot from cdrom.  The same thing happens with a diskette 
image, then proceed from cdrom.

The cdrom iso was downloaded from a mirror (I forget which).
Comment 3 Mike Davis 2000-10-19 09:25:50 EDT
Problem has been resolved.  A corrupted comps file.  I downloaded another iso 
image from eecs.umich.edu and re burnt the cd which now works fine.

The original (corrupted) iso image came from cs.wisc.edu.
Comment 4 Brock Organ 2000-10-19 11:50:50 EDT
glad to hear your problem is resolved ... thanks for your report!

Note You need to log in before you can comment on or make changes to this bug.