Bug 193202 - php-pdo package ought to Provide: php-pdo(ABI)
php-pdo package ought to Provide: php-pdo(ABI)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 20:37 EDT by Chris Weyl
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 07:55:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2006-05-25 20:37:51 EDT
php-pdo ought to Provide an abi of its own, as I discovered during a
mismatched-upgrade of my own the other day:

"PHP Fatal error:  PDO: driver mysql requires PDO API version 20060409; this is
PDO version 20051128 in Unknown on line 0"

Note that was my own mysql pdo from when the box was fc4, but since there are
bdo objects not packaged with php on fedora, exporting the PDO API/ABI would
allow externally built pdo packages to stay in sync with fedora php.
Comment 1 Joe Orton 2006-10-24 07:55:10 EDT
Thanks for the report, fixed in the -5.1.6 update:

http://www.redhat.com/archives/fedora-package-announce/2006-October/msg00028.html


Note You need to log in before you can comment on or make changes to this bug.