Bug 1932044 (CVE-2020-35524) - CVE-2020-35524 libtiff: Heap-based buffer overflow in TIFF2PDF tool
Summary: CVE-2020-35524 libtiff: Heap-based buffer overflow in TIFF2PDF tool
Keywords:
Status: NEW
Alias: CVE-2020-35524
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1932045 1934518 1934519 1945546 1932046 1945547
Blocks: 1932047 1932054
TreeView+ depends on / blocked
 
Reported: 2021-02-23 19:51 UTC by Pedro Sampaio
Modified: 2021-04-01 09:22 UTC (History)
7 users (show)

Fixed In Version: libtiff 4.2.0
Doc Type: If docs needed, set a value
Doc Text:
A heap-based buffer overflow flaw was found in libtiff in the handling of TIFF images in libtiff's TIFF2PDF tool. A specially crafted TIFF file can lead to arbitrary code execution. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Pedro Sampaio 2021-02-23 19:51:24 UTC
A flaw was found in libtiff 4.1.0. A heap-based buffer overflow exists in the handling of TIFF images in libtiff's TIFF2PDF tool. A specially crafted TIFF file can lead to arbitrary code execution.

References:

https://gitlab.com/rzkn/libtiff/-/commit/7be2e452ddcf6d7abca88f41d3761e6edab72b22
https://gitlab.com/libtiff/libtiff/-/merge_requests/159

Comment 1 Pedro Sampaio 2021-02-23 19:52:01 UTC
Created libtiff tracking bugs for this issue:

Affects: fedora-all [bug 1932046]


Created mingw-libtiff tracking bugs for this issue:

Affects: fedora-all [bug 1932045]


Note You need to log in before you can comment on or make changes to this bug.