Bug 193226 - "passwd:compat" no longer useful in /etc/nsswitch.conf
"passwd:compat" no longer useful in /etc/nsswitch.conf
Status: CLOSED DUPLICATE of bug 192072
Product: Fedora
Classification: Fedora
Component: man-pages (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2006-05-26 06:13 EDT by Ian Collier
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-05-26 07:50:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ian Collier 2006-05-26 06:13:02 EDT
Description of problem:

"man nsswitch.conf" says:

       An  example /etc/nsswitch.conf (namely, the default used when /etc/nss-
       witch.conf is missing):

       passwd:         compat
       group:          compat
       shadow:         compat

This used to work in FC4, but somewhere along the line libnss_compat seems to
have been changed so that this fails if the NIS service is currently down.  This
means a load of the boot scripts (such as the one that starts udev) emit errors
such as "root: no such user" because they are executed before NIS comes up.  You
now need to write something like:

       passwd:         compat [NOTFOUND=return] files
       group:          compat [NOTFOUND=return] files
       shadow:         compat [NOTFOUND=return] files

so (unless this is a bug in glibc) I suggest the documentation be changed to match.

Version-Release number of selected component (if applicable):
Comment 1 Ivana Varekova 2006-05-26 07:50:18 EDT

*** This bug has been marked as a duplicate of 192072 ***

Note You need to log in before you can comment on or make changes to this bug.