Bug 193236 - /sbin/ifup fails for Type=Bonding and BRIDGE=br0
/sbin/ifup fails for Type=Bonding and BRIDGE=br0
Status: CLOSED DUPLICATE of bug 463014
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 10:18 EDT by Rafal Wijata
Modified: 2014-03-16 22:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 15:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup patch to handle bondX devices (1.15 KB, patch)
2007-10-08 19:34 EDT, Kilian Cavalotti
no flags Details | Diff

  None (edit)
Description Rafal Wijata 2006-05-26 10:18:25 EDT
Description of problem:
IF bond type device is to be part of bridge device, the bond device is not
initializing, and therefore inoperative

Version-Release number of selected component (if applicable):


How reproducible:
configure bond device and make it part of bridge device

Steps to Reproduce:
/etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
TYPE=Bridge
BOOTPROTO=none
IPADDR=192.168.1.1
NETMASK=255.255.255.0
ONBOOT=yes
USERCTL=no
DELAY=0
STP=off

/etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
TYPE=Bonding
BRIDGE=br0
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

the bond0 device is not initialized(slaves are not enslaved).
the bond0 device is not added to the br0 device (cause it's added prematurly -
before enslaving slaves)
  
Actual results:
neither bond0 nor br0 is properly configured by /sbin/ifup

Expected results:
All OK

Additional info:
/sbin/ifup:192 brctl addif statement fails becaouse no enslaved devices in bond0
/sbin/ifup:196 exit 0 statement makes bond0 to exit without enslaving slaves.
Comment 1 Rafal Wijata 2006-07-12 04:44:28 EDT
is there anybody out there ?
Comment 2 Bill Nottingham 2006-07-12 09:54:57 EDT
This does look like an issue. No patch available as of yet.
Comment 3 Rafal Wijata 2006-07-20 04:25:14 EDT
I also noticed, that even I initialize such config by hand, then during system
shutdown bridge device can't take itself down, as not all subdevices were shut down.
Comment 4 Rafal Wijata 2006-12-15 05:54:27 EST
It's going to be 7 months on Xmas ;)
Comment 5 Kilian Cavalotti 2007-10-08 19:34:33 EDT
Created attachment 220341 [details]
ifup patch to handle bondX devices

This hasn't been fixed in over a year, which is really lame for a so-called
"Enterprise-grade" distribution.

Here's a 5 minutes patch. I'm sure you can do better.
Comment 6 Rafal Wijata 2008-07-28 04:22:47 EDT
It's over two years now! Wow, great speed fixing easy things! Surely RHEL gains
my trust here.
Comment 7 Bill Nottingham 2008-09-23 15:14:31 EDT

*** This bug has been marked as a duplicate of bug 463014 ***

Note You need to log in before you can comment on or make changes to this bug.