Bug 193237 - Move /etc/firmware to /lib/firmware
Move /etc/firmware to /lib/firmware
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2006-05-26 10:38 EDT by Robert Scheck
Modified: 2008-03-03 15:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 15:08:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff of microcode_ctl spec files (1.31 KB, patch)
2006-05-26 10:40 EDT, Robert Scheck
no flags Details | Diff
Updated microcode_ctl patch (1.69 KB, patch)
2006-05-26 10:41 EDT, Robert Scheck
no flags Details | Diff
Diff of microcode_ctl init files (300 bytes, patch)
2006-05-26 10:43 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2006-05-26 10:38:19 EDT
Description of problem:
Well, did you ever have a look to /etc/firmware? If yes, you noticed, that 
except the microcode update nothing is there and the directory /etc/firmware 
itself isn't owned by any package.

I would suggest moving of /etc/firmware to /lib/firmware. Both is available
at booting time, but /lib/firmware looks more suitable to me, because kernel 
driver requiring firmware (like ipw2200, bcm43xx, prism54 etc.) are loading 
their stuff from there.

And yes, I know that it doesn't use the exact same infrastructure, but it
would make more sense in my eyes to group them - same opinion returned from
Bill Nottingham, yesterday in IRC.

Version-Release number of selected component (if applicable):
microcode_ctl-1.13-1.30

How reproducible:
ls -l /etc/firmware
rpm -qf /etc/firmware

Actual results:
A /etc/firmware directory only for one microcode_ctl file and the rest of the 
world is putting its firmware files into /lib/firmware.

Expected results:
Merge /etc/firmware into /lib/firmware.

Additional info:
Patches containing this expected change are attached, but they also clean up
the spec file a bit... ;-)
Comment 1 Robert Scheck 2006-05-26 10:40:04 EDT
Created attachment 130023 [details]
Diff of microcode_ctl spec files
Comment 2 Robert Scheck 2006-05-26 10:41:50 EDT
Created attachment 130024 [details]
Updated microcode_ctl patch
Comment 3 Robert Scheck 2006-05-26 10:43:36 EDT
Created attachment 130025 [details]
Diff of microcode_ctl init files
Comment 4 Robert Scheck 2006-09-23 13:18:02 EDT
Ping?
Comment 5 Robert Scheck 2006-10-15 12:36:45 EDT
Jon - still alive? Could you please fix this bug report soon? Thanks...
Comment 6 Robert Scheck 2006-10-25 16:08:38 EDT
Ping?
Comment 7 Jon Masters 2006-11-10 06:06:23 EST
The two directories are not really doing the same thing - this package handles
microcode, not the same kind of firmware that the kernel is looking for. But I
do get the point, we do patch microcode_ctl to change the location and that is
open for some debate. I haven't forgotten about this issue, just I'm not sure
what the best thing to do is just yet - I'll talk to davej/others a little for
comments about why it became /etc/firmware in the first place so I know the history.
Comment 8 Robert Scheck 2006-11-10 17:18:38 EST
Okay. And when it's /etc/firmware further on, then please OWN the stuff your 
package delivers (otherwise request filesystem package to add the /etc/firmware 
directory), please... ;-)
Comment 9 Dave Jones 2006-11-12 02:41:03 EST
I don't really have an opinion on where it comes from, as long as it works.
Comment 10 Robert Scheck 2006-12-19 18:04:51 EST
Common, please :)
Comment 11 Robert Scheck 2007-03-10 20:15:46 EST
Ping?
Comment 12 Robert Scheck 2007-07-15 15:42:48 EDT
PING?
Comment 13 Jon Masters 2007-08-20 02:40:06 EDT
Sorry. I've added this to my TODO and will get it fixed.

Jon.
Comment 14 Robert Scheck 2007-09-02 21:26:30 EDT
Will we get this into F8?
Comment 15 Jarod Wilson 2008-03-03 15:08:53 EST
Didn't even know this bug existed, but when doing some microcode_ctl work a week
or two ago, I actually moved microcode.dat to /lib/firmware in rawhide.

Note You need to log in before you can comment on or make changes to this bug.