Bug 193258 - qt4: /usr/bin/ld: cannot find -lXi
Summary: qt4: /usr/bin/ld: cannot find -lXi
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-26 17:06 UTC by Frank Büttner
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 20:35:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frank Büttner 2006-05-26 17:06:18 UTC
You have create package where it is not possible to build apps using Qt4.
When I use the orginal packe from TT all works fine. When using your package it
is not posible to compile apps. Because you have modifed the linker paramter.
And so linking fails at FC4 with /usr/bin/ld: cannot find -lXi

Comment 1 Rex Dieter 2006-05-26 17:23:57 UTC
Looks like -lXi needs to be stripped from the output of
pkgconfig --libs QtGui

Comment 2 Frank Büttner 2006-05-26 17:33:02 UTC
No that is not the problem. You Qt packe search in the wrong place for the lib.
When I use my own QT build the lib Xi will be linked correct.

Comment 3 Rex Dieter 2006-05-26 17:44:48 UTC
Either solution works, but I prefer stripping the extra lib baggage.

Try (as root),
sed -i -e "s|-lXi ||g" /usr/lib/qt4/lib/*.pc 
and you should be fine.

Comment 4 Frank Büttner 2006-05-26 17:47:20 UTC
So I have found that the error you must include the libdir for the X11R6 libs.
-L/usr/X11R6/lib is missing in your qt compiler profile

Comment 5 Rex Dieter 2006-05-26 17:55:55 UTC
I'm planning on putting -L/usr/X11R6/lib back (to be safe(r)), and remove -lXi.

Comment 6 Frank Büttner 2006-05-26 18:04:59 UTC
no that will be wrong -lXi and -L/usr/X11R6/lib is needed.

Comment 7 Rex Dieter 2006-05-26 20:35:57 UTC
new build queue'd, to appear soon in a repo near you...

* Fri May 26 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1.3-5
- strip -lXi from .pc files (#193258)
- simplify sql plugin builds via %buildSQL macro
- -libdir %qt_libdir 




Note You need to log in before you can comment on or make changes to this bug.