This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 193287 - System not picking up extra kernel params when kickstarting
System not picking up extra kernel params when kickstarting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
:
Depends On: 234034
Blocks: 173427
  Show dependency treegraph
 
Reported: 2006-05-26 16:44 EDT by Mike McCune
Modified: 2007-10-29 21:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 22:59:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2006-05-26 16:44:02 EDT
tcameron was working on site with a customer doing a demo of kickstarting
systems with "Extra Kernel Parameters".  He ran into an issue where the
kickstarted system doesn't appear to actually have the extra parameters after
its done KSing.  

Steps to reproduce:

1) Create a Kickstart profile
2) On the Options page add some extra parameters: vga=791 noexec=off
3) Kickstart a system using this Profile
4) notice that after kickstarting /etc/grub.conf doesn't contain the extra
parameters.  

I verified that rhnActionKickstart is properly setup with the extra stuff:

ks=http://rlx-3-06.rhndev.redhat.com/ty/CuEn9R82 ksdevice=eth0 vga=791 noexec=off

but when rhn_check goes to grab/process the kickstart action it doesn't seem to
be doing the right thing with those options.

This looks like a client issue to me since it appears we are setting everything
up in the DB correctly.  This was in a 4.0.6 satellite.
Comment 1 Bret McMillan 2006-06-07 13:57:11 EDT
Over to jbowes to investigate... probably something within the autoks pkg itself.
Comment 2 Thomas Cameron 2006-06-07 14:26:51 EDT
Note this was not via autoks, it was a PXE boot.
Comment 3 James Bowes 2006-06-08 11:37:07 EDT
Aren't the kernel parameters just for passing to the kernel during the
kickstart? I'm pretty certain that to get extra kernel parameters in grub.conf
on the installed system, you'd have to put them in the kickstart file itself.
Comment 4 James Bowes 2006-06-14 11:08:22 EDT
IIRC, the status of this one is that the UI is a bit confusing, since it doesn't
really let you know that the Extra parameters are just for the auto-ks
kickstart, and not for PXE boot. So maybe it should say something like "Extra
Parameters (Auto Kickstart Only)"
Comment 5 Mike McCune 2006-06-14 11:28:12 EDT
Added wording to this page to indicate its auto-kickstart only.  Moved to rhn420
since rhn410 is going final soon and no time left to get this string update to
the translators.

Comment 6 Mike McCune 2006-06-19 20:19:59 EDT
move to ON_QA 
Comment 7 Mike McCune 2006-06-19 20:25:35 EDT
really move to ON_QA !!!!
Comment 8 Steve Salevan 2006-06-28 16:56:27 EDT
QA Contact -> ssalevan

This is still ON_DEV at the moment, so I'm moving it over there.
Comment 9 Mike McCune 2007-03-23 16:36:16 EDT
on-qa
Comment 10 wes hayutin 2007-03-26 13:42:50 EDT
looks like the same problem we're having w/ config mang... package problems...

D: Adding to transaction set ['auto-kickstart-ks-rhel-i386-as-4', '1.12', '2',
'', 'noarch', '2300', 'rhn-tools-rhel-4-as-i386']
D: Checking for dependencies
D: RPM returned 1 deps.
D: Processing dependency (('auto-kickstart-ks-rhel-i386-as-4', '1.12', '2'),
('auto-kickstart', '1.12'), 12, None, 0)
D: Dependencies: [('auto-kickstart-ks-rhel-i386-as-4', 'auto-kickstart')]
D: Sending back response (31, 'Failed: There was a File Not Found error. The
error was: File Not Found: \nFile Not Found:
auto-kickstart-1.13-1.el4.noarch\n\nError Message:\n Package not found\nError
Class Code: 17\nError Class Info: File not found.\nExplanation: \n     An error
has occurred while processing your request. If this problem\n     persists
please enter a bug report at bugzilla.redhat.com.\n     If you choose to submit
the bug report, please be sure to include\n     details of what you were trying
to do when this error occurred and\n     details on how to reproduce this
problem.\n', {'missing_package_error': File Not Found:
File Not Found: auto-kickstart-1.13-1.el4.noarch

Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
, 'version': '0', 'name': 'packages.update.file_not_found'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or
package list recently updated)', {})

unable to test this until package issues are resolved..
Comment 11 wes hayutin 2007-03-28 22:24:08 EDT
I think this fails QA... are the above extra parameters just for the one time
boot for kickstart or should they be added to grub.conf.. 

Jbowes and mmcune spoke about this in comments 3-5 but added an issue of pxe boot. 
So just following the test plan this fails...

[root@fjs-0-06 proc]# cat /etc/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/myvg/rootvol
#          initrd /initrd-version.img
#boot=/dev/hde
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-42.EL)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-42.EL ro root=/dev/myvg/rootvol
        initrd /initrd-2.6.9-42.EL.img
[root@fjs-0-06 proc]# 


[root@fjs-0-06 ~]# cat anaconda-ks.cfg 
# Kickstart file automatically generated by anaconda.

install
url --url http://fjs-0-13.rhndev.redhat.com/ty/wMjJbcAX
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
skipx
network --device eth0 --bootproto dhcp
rootpw --iscrypted $1$6U0b3CDn$pJQ071vNomLZnTuJGopLa.
firewall --disabled
selinux --permissive
authconfig --enableshadow --enablemd5
timezone America/New_York
bootloader --location=mbr
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#clearpart --all
#part /boot --fstype ext3 --size=200
#part pv.100000 --size=1000 --grow
#part swap --size=1000 --maxsize=2000
#volgroup myvg --pesize=32768 pv.100000
#logvol / --fstype ext3 --name=rootvol --vgname=myvg --size=1000 --grow

%packages --resolvedeps
grub
e2fsprogs
kernel
lvm2

%post
[root@fjs-0-06 ~]# 

Comment 12 wes hayutin 2007-03-28 22:28:53 EDT
found additional info.. /var/log/messages is stating that the machine was not
booted w/ the provided options.. the machine has only been booted the one time..

 28 21:55:19 fjs-0-06 kernel: Kernel command line: ro root=/dev/myvg/rootvol
Mar 28 21:55:19 fjs-0-06 kernel: Initializing CPU#0
Mar 28 21:55:19 fjs-0-06 kernel: CPU 0 irqstacks, hard=c03ff000 soft=c03fe000
Comment 13 Jan Pazdziora 2007-04-30 08:59:48 EDT
Taking this bug over from Mike's queue.
Comment 14 Jan Pazdziora 2007-04-30 10:24:08 EDT
For PXE, the kernel parameters are specified in the PXE configuration file
(/tftpboot/linux-install/pxelinux.cfg/default) and are parsed way before parsing
ks=... can kick in.

So the option cannot be for PXE.

As the System Details -> Troubleshooting -> Extra Kernel Parameters now has "for
auto-kickstart only" added to it and the RHN Engineers agreed that these
parameters are not supposed to modify grub.conf, I'm putting this ON_QA.

The test plan is -- upon auto-kickstart (upon that one reboot), the kernel
parameters should be used. Not in other circumstances.
Comment 15 wes hayutin 2007-05-01 08:52:56 EDT
k.. I see this prior to reboot for kickstart which is good..
D: do_call kickstart.initiate ('ks-rhel-i386-server-5',
'ks=http://fjs-0-19.rhndev.redhat.com/ty/W7zsIreb ksdevice=eth0 vga=791
noexec=off', ''

k.. the extra kernel parameters are being used for the kickstart session..
verified..
Comment 16 Mike McCune 2007-06-20 10:56:38 EDT
tested an rlx kickstart with added params:

console=ttyS0,38400n8 acpi=noirq

and it worked properly.
Comment 17 Brandon Perkins 2007-06-25 22:59:41 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.