Bug 1932961 - Installation summary screen at F34 spins doesn't show anymore the option to change Network and Host names
Summary: Installation summary screen at F34 spins doesn't show anymore the option to c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-02-25 13:27 UTC by Geraldo Simião
Modified: 2021-03-29 00:15 UTC (History)
8 users (show)

Fixed In Version: anaconda-34.24.5-2.fc34 anaconda-34.24.6-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-02 04:37:31 UTC
Type: Bug


Attachments (Terms of Use)
F34 KDE spin anaconda summary screen without host name option (145.82 KB, image/png)
2021-02-25 13:27 UTC, Geraldo Simião
no flags Details
F34 XFCE spin anaconda summary screen without host name option (123.75 KB, image/png)
2021-02-25 13:34 UTC, Geraldo Simião
no flags Details
F33 KDE spin anaconda summary screen with host name option - as expected (170.42 KB, image/png)
2021-02-25 13:35 UTC, Geraldo Simião
no flags Details
F34 KDE spin anaconda summary screen with correct host name option - after new update (168.88 KB, image/png)
2021-02-26 13:05 UTC, Geraldo Simião
no flags Details

Description Geraldo Simião 2021-02-25 13:27:59 UTC
Created attachment 1759322 [details]
F34 KDE spin anaconda summary screen without host name option

Description of problem:

Since the ISO images for the F34 spins where ready I noticed something different on the anaconda procedures to installation: on the installation summary screen it doesn't show anymore the option to change Network and Host name, as it does on the F33 and earlier versions. I saw this on kde spin and xfce spin too. Now, on F34 it installs with the default "fedora" host name, and if you wanna change it you must do it after installation, with the command "hostnamectl set-hostname".

I send attached some screenshots from anaconda for the F33 and F34 kde and xfce spins...


Version-Release number of selected component (if applicable):
All F34 spins

How reproducible:
Allways

Steps to Reproduce:
1.start a live session on VM or Baremetal witha SPIN image
2.try the install to disk procedure
3.see on the summary screen that there's no more the "network and host name" option

Actual results:
Doesn't allow user to graphicaly set host name and network from the anaconda installer

Expected results:
Allow user tho set both

Additional info:

Radek Vykydal (rvykydal@redhat.com) said on the devel list that this seems to be a fallout of https://github.com/rhinstaller/anaconda/commit/6b80b7b33c312faa69c22e4bdfe758f186d32786 and oriented me to open this ticket and set it with F34 Beta freeze exception request.

Comment 1 Geraldo Simião 2021-02-25 13:34:38 UTC
Created attachment 1759323 [details]
F34 XFCE spin anaconda summary screen without host name option

Comment 2 Geraldo Simião 2021-02-25 13:35:44 UTC
Created attachment 1759324 [details]
F33 KDE spin anaconda summary screen with host name option - as expected

Comment 3 Vendula Poncova 2021-02-25 14:01:44 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/3199

Comment 4 Fedora Blocker Bugs Application 2021-02-25 16:36:52 UTC
Proposed as a Freeze Exception for 34-beta by Fedora user m4rtink using the blocker tracking app because:

 Some of the expected Anaconda spokes are missing on the non-Gnome live images and we should fix that.

Comment 5 Adam Williamson 2021-02-25 17:44:04 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/255 , marking accepted.

Comment 6 Fedora Update System 2021-02-25 18:25:25 UTC
FEDORA-2021-a432247223 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a432247223

Comment 7 Fedora Update System 2021-02-25 23:45:43 UTC
FEDORA-2021-a432247223 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a432247223`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a432247223

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Geraldo Simião 2021-02-26 13:02:55 UTC
Tested today with the new update (https://bodhi.fedoraproject.org/updates/FEDORA-2021-a432247223 ) and it is fixed now indeed. Attaching a print from the summary screen with the correct options back.
Thank you all for the great work.
:D

Comment 9 Geraldo Simião 2021-02-26 13:05:18 UTC
Created attachment 1759484 [details]
F34 KDE spin anaconda summary screen with correct host name option - after new update

Now, after the update https://bodhi.fedoraproject.org/updates/FEDORA-2021-a432247223 the summary is back as it was on F33. Tried today and installation worked as expected.

Comment 10 Geraldo Simião 2021-02-28 11:46:35 UTC
Until Fedora-KDE-Live-x86_64-34-20210226.n.0.iso this new version still doesn't get shipped with the ISO.
Perhaps waiting to get to stable repo?

Comment 11 Fedora Update System 2021-03-02 04:37:31 UTC
FEDORA-2021-a432247223 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Adam Williamson 2021-03-03 23:41:42 UTC
Geraldo: yes, composes are done from the stable package set. It should be in the most recent compose (Fedora-34-20210303.n.0) I believe, if you can verify that'd be great. Thanks!

Comment 13 Geraldo Simião 2021-03-04 02:34:04 UTC
Yes, I tested today with the new iso 20210303 and it did great, it's fixed already right from the downloaded iso.
Now it all works fine, just it was om f33 spins. Thanks all of you.

Comment 14 Adam Williamson 2021-03-05 19:39:04 UTC
Awesome, thank you for the report and the testing!

Comment 15 Fedora Update System 2021-03-22 17:53:27 UTC
FEDORA-2021-a12fa51168 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a12fa51168

Comment 16 Fedora Update System 2021-03-23 02:01:36 UTC
FEDORA-2021-a12fa51168 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a12fa51168`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a12fa51168

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-03-29 00:15:24 UTC
FEDORA-2021-a12fa51168 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.