Bug 193298 - Libbind patch in squid SRPM fails
Libbind patch in squid SRPM fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 18:12 EDT by John Horne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-28 07:42:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Horne 2006-05-26 18:12:52 EDT
Description of problem:
The squid-2.5.STABLE12-libbind.patch in the current squid SRPM causes
an error during the rebuild.

Version-Release number of selected component (if applicable):
Squid version squid-2.5.STABLE13-1

How reproducible:
Every time.

Steps to Reproduce:
1. Download and install lastest version of FC5 squid SRPM
2. Enter commands:
     cd /usr/src/redhat/SPECS
     rpmbuild -ba squid.spec >/tmp/out 2>&1
3.
  
Actual results:
View output file /tmp/out and it will show:

     checking for main in -lregex... no
     ./configure: line 7195: test: =: unary operator expected
     checking for main in -lm... yes

Expected results:
No error should be generated.

Additional info:

The patch removes the configure test for gethostbyname in lbind by commenting
it all out. However, as the last 2 lines of the patch shows:

    if test $ac_cv_lib_bind_gethostbyname= "no" ; then
     case "$host" in

Because all the test is commented the variable '$ac_cv_lib_bind_gethostbyname'
is never set - hence the test is testing something undefined against "no" and so
causes the error.

I suspect because of this error the subsequent tests of lresolv in configure are
skipped as well. This makes me wonder if the patch is needed; squid seems to
work fine despite the error.


John.
Comment 1 John Horne 2006-05-26 18:56:05 EDT
1) This bug also exists under FC4.

2) By modifying the last commented-out line of the patch from:

       +#fi
   to
       +ac_cv_lib_bind_gethostbyname=no

   the patch now works correctly, and the output file (/tmp/out) shows that
   additional checks are being made (this was under FC4):

       checking for main in -lregex... no
       checking for inet_aton in -lresolv... yes
       checking for inet_aton in -l44bsd... no
       checking for main in -lresolv... yes
       checking for main in -lm... yes

   The middle 3 lines are new - because the patch now works.

John.
Comment 2 Martin Stransky 2006-05-28 07:42:31 EDT
Fixed in rawhide, thanks.

Note You need to log in before you can comment on or make changes to this bug.