Bug 1933028 - [csi-driver] ovirt_password secret must accept any printable character.
Summary: [csi-driver] ovirt_password secret must accept any printable character.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Janos Bonic
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-25 14:39 UTC by Gal Zaidman
Modified: 2022-07-14 15:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-07-14 15:27:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Gal Zaidman 2021-02-25 14:39:16 UTC
Description of problem:
This bug was created to continue fix a problem that was found on:
https://bugzilla.redhat.com/show_bug.cgi?id=1896320

As Benny reported on C#1[1]:
```
E1110 09:21:15.641660       1 starter.go:36] yaml: line 3: found character that cannot start any token

Ultimately the issue is caused by the ovirt-api password starting with a reserved character, this can be resolved by editing the ovirt-credentials object and wrap the password with quotes.

I created a PR to fail earlier so the logs aren't as difficult to read
```

The driver should be able to accept any printable character and shouldn't limit the ovirt password.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1896320#c1

Comment 1 Gal Zaidman 2021-03-30 15:05:46 UTC
due to capacity constraints, we will be revisiting this bug in the upcoming sprint

Comment 2 Gal Zaidman 2021-04-29 11:37:15 UTC
due to capacity constraints, we will be revisiting this bug in the upcoming sprint


Note You need to log in before you can comment on or make changes to this bug.