Bug 193304 - Surprising behaviour of "rpm -F" with multiple architectures installed
Surprising behaviour of "rpm -F" with multiple architectures installed
Status: CLOSED DUPLICATE of bug 88623
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 19:11 EDT by Kai Engert (:kaie)
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-29 11:09:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2006-05-26 19:11:06 EDT
Description of problem:
Surprising behaviour of "rpm -F" with multiple architectures installed.

Version-Release number of selected component (if applicable):
rpm-4.4.2-15.2

How reproducible:
Let me describe it abstractly.
You need 4 packages:
- pack-1.i386.rpm
- pack-1.x86_64.rpm
- pack-2.i386.rpm
- pack-2.x86_64.rpm
Then follow the steps

Steps to Reproduce:
1. rpm -ivh pack-1.x86_64.rpm
2. rpm -ivh pack-1.i386.rpm
3. rpm -Fvh pack-2.x86_64.rpm
all steps so far installed the package, now
4. rpm -Fvh pack-2.i386.rpm
this does nothing. 
  
Actual results:
A test using
  rpm -qi pack.i386
shows that we have still pack-1.i386 installed.

Expected results:
Command in step 4 should have installed pack-2.i386
Comment 1 Jeff Johnson 2006-05-29 08:18:41 EDT
Use -U not -i.
Comment 2 Kai Engert (:kaie) 2006-05-29 09:29:52 EDT
I disagree this is not a bug.
Did you misunderstand my explanation? Sorry if it has not been clear. I did not
use -i in the failing step, I used -F.
Let me rephrase:

Option -F should "update package that is already installed to the latest version".

But option -F did not work, it did not "freshen". I did not upgrade the package.
I did nothing.

I think step 4, using -F, should have installed the newer pack-2.i386.rpm
But it did not.
Nothing happened.
That is the bug.

Comment 3 Jeff Johnson 2006-05-29 11:09:37 EDT
Ah, --freshen is your concern. Sorry for being dense.

*** This bug has been marked as a duplicate of 88623 ***

Note You need to log in before you can comment on or make changes to this bug.