Bug 1933105 - Wrong character for Numpad dot key
Summary: Wrong character for Numpad dot key
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-25 16:51 UTC by joshas
Modified: 2021-03-10 06:38 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-25 17:33:13 UTC
Type: Bug


Attachments (Terms of Use)

Description joshas 2021-02-25 16:51:57 UTC
Description of problem:
Pressing "dot" (period) key on Numpad, when Num Lock is enabled should produce "," (comma) character when Lithuanian keyboard layout is selected. Currently it always writes "." (dot/period) character, which is not correct decimal separator for Lithuanian keyboard layout. Using GNOME DE on Wayland.

Version-Release number of selected component (if applicable):
n/a

How reproducible:
Always.

Steps to Reproduce:
1. Switch to "Lithuanian" keyboard layout.
2. Turn on Num Lock on Numpad
3. Press "." (dot/period/Del) key on NumPad

Actual results:
Character "." (dot/period) is written on screen.

Expected results:
Character "," (comma) is written on screen.


Additional info:
Not really sure when this change happened, but probably not longer than a month ago. Noticed today on desktop PC.

Comment 1 joshas 2021-02-25 17:33:13 UTC
Looks like this is issue only with LibreOffice Calc. I'll report it to LibreOffice issue tracker.

Comment 2 Peter Hutterer 2021-03-10 06:38:20 UTC
slighty late but just ftr, the keypad comma is assigned its own keysym in the XKB layouts: KP_Decimal. Interpretation of what that means (comma, dot, something else) is up to the client and part of the locale information. So it's not a keyboard layout issue.


Note You need to log in before you can comment on or make changes to this bug.