Bug 19332 - LS-120 as sole floppy
Summary: LS-120 as sole floppy
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 19:56 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-12 18:42:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-18 19:56:31 UTC
A machine that uses an LS-120 SuperFloppy as its only floppy drive encounters a problem writing a boot disk as anaconda is hardcoded to use 
/dev/fd0 in that part of the script.  Since the LS-120 is an ATA drive it is mounted via the /dev/hdX devices.  For the unprepared this is 
interpreted as a freeze when in actuality it is just a VERY long pause until the file system creation fails out and the user can select "Skip ..."  
Obviously, this is not a good thing as without a boot floppy, an unsuccessful install/upgrade will leave a machine in a ... shall we say, 
interesting state.

Comment 1 Michael Fulbright 2000-10-19 21:48:43 UTC
Please verify Brock.

Comment 2 Ignacio Vazquez-Abrams 2000-10-19 22:58:11 UTC
Suggestion:

If an LS-120 drive is detected and no floppy drive is detected, the user should
be prompted to insert a >1.44MB floppy< for bootdisk (NOT LS-120 disk), and LILO
is put on with the proper BIOS and CHS parameters (disk=/dev/hda\n bios=0x80\n
cylinders=...\n heads=...\n sectors=...).

BTW: I once put an old distro (6.1, I think) an an LS-120 disk by itself.
Freaky, huh?

Comment 3 Brock Organ 2000-11-01 21:20:19 UTC
reassigning these to dale@redhat.com for further review ...

Comment 4 Dale Lovelace 2000-12-01 15:30:26 UTC
I have verified that if your only floppy is a LS-120 you are not able to create
a bootdisk.

Comment 5 Erik Troan 2001-01-12 17:35:52 UTC
I can't make a boot floppy work in our ls120 at all. I've done:

	drive=/dev/hdd
		bios=0x00
		heads=2
		cylinders=80
		sectors=18

I've tried w/ and w/o the geometry, w/ and w/o linear. In all cases, lilo stops
after lil.

Comment 6 Erik Troan 2001-01-12 18:42:52 UTC
mkbootdisk 1.3 uses syslinux rather then lilo, and seems to work fine


Note You need to log in before you can comment on or make changes to this bug.