Bug 193327 - Gnucash crashes when adding a new account
Gnucash crashes when adding a new account
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-27 09:12 EDT by Brian Gerst
Modified: 2014-03-16 22:59 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.0.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 19:33:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Gerst 2006-05-27 09:12:16 EDT
Description of problem:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 47919099484736 (LWP 18842)]
0x000000311de28ec1 in gtk_tree_model_get_valist () from
/usr/lib64/libgtk-x11-2.0.so.0
(gdb) bt
#0  0x000000311de28ec1 in gtk_tree_model_get_valist () from
/usr/lib64/libgtk-x11-2.0.so.0
#1  0x000000311de29161 in gtk_tree_model_get () from /usr/lib64/libgtk-x11-2.0.so.0
#2  0x00002b950829ba14 in sort_by_string (f_model=Variable "f_model" is not
available.
) at gnc-tree-view-account.c:287
#3  0x000000311de2f2ab in gtk_tree_model_filter_convert_child_iter_to_iter ()
from /usr/lib64/libgtk-x11-2.0.so.0
#4  0x000000311de316bd in gtk_tree_model_sort_get_model () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#6  0x000000311c61c563 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#7  0x000000311c61d90c in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#8  0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#9  0x000000311de2ac12 in gtk_tree_model_filter_clear_cache () from
/usr/lib64/libgtk-x11-2.0.so.0
#10 0x000000311de2e33c in gtk_tree_model_filter_convert_child_iter_to_iter ()
from /usr/lib64/libgtk-x11-2.0.so.0
#11 0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#12 0x000000311c61c563 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#13 0x000000311c61d90c in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#14 0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#15 0x00002b950828eaa9 in gnc_tree_model_account_path_changed (model=0xb84e40,
path=0xd10ae0) at gnc-tree-model-account.c:1454
#16 0x00002b950829076e in gnc_tree_model_account_event_handler (entity=Variable
"entity" is not available.
) at gnc-tree-model-account.c:1553
#17 0x00002b9507784dc4 in qof_event_generate_internal (entity=0xbc4260,
event_id=8, event_data=0x0) at qofevent.c:247
#18 0x00002b95078bd022 in xaccGroupInsertAccount (grp=0xc263a0, acc=0xbc4260) at
Group.c:798
#19 0x00002b95078bd97b in xaccAccountInsertSubAccount (adult=0xc6d2f0,
child=0xbc4260) at Group.c:740
#20 0x00002b950824dc6b in gnc_finish_ok (aw=0xbab9b0, change_type=Variable
"change_type" is not available.
) at dialog-account.c:381
#21 0x00002b950824eaab in gnc_account_window_response_cb (dialog=0xb5e160,
response=-5, data=Variable "data" is not available.
) at dialog-account.c:961
#22 0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#23 0x000000311c61c563 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#24 0x000000311c61d90c in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#25 0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#26 0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#27 0x000000311c61c563 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#28 0x000000311c61d90c in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#29 0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#30 0x000000311dc7a5c9 in gtk_button_set_alignment () from
/usr/lib64/libgtk-x11-2.0.so.0
#31 0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#32 0x000000311c61c9c0 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#33 0x000000311c61d90c in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#34 0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#35 0x000000311dc78b29 in gtk_button_released () from /usr/lib64/libgtk-x11-2.0.so.0
#36 0x000000311dd4f9e1 in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#37 0x000000311c60b26a in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#38 0x000000311c61cb91 in g_signal_override_class_closure () from
/lib64/libgobject-2.0.so.0
#39 0x000000311c61d7a7 in g_signal_emit_valist () from /lib64/libgobject-2.0.so.0
#40 0x000000311c61dbc3 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#41 0x000000311de62d7e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#42 0x000000311dd47d13 in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#43 0x000000311dd48e71 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#44 0x000000311e54b2bc in gdk_add_client_message_filter () from
/usr/lib64/libgdk-x11-2.0.so.0
#45 0x000000311c42d2ea in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#46 0x000000311c430465 in g_main_context_check () from /lib64/libglib-2.0.so.0
#47 0x000000311c43078d in g_main_loop_run () from /lib64/libglib-2.0.so.0
#48 0x000000311dd49283 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#49 0x00002b9508278809 in gnc_ui_start_event_loop () at gnc-gnome-utils.c:368
#50 0x00000000004027a1 in inner_main (closure=Variable "closure" is not available.
) at gnucash-bin.c:476
#51 0x00002b9508cafe9f in scm_boot_guile () from /usr/lib64/libguile.so.17
#52 0x00002b9508c87e2a in scm_char_upcase () from /usr/lib64/libguile.so.17
#53 0x00002b9508cea305 in scm_c_catch () from /usr/lib64/libguile.so.17
#54 0x00002b9508c88281 in scm_i_with_continuation_barrier () from
/usr/lib64/libguile.so.17
#55 0x00002b9508c88320 in scm_c_with_continuation_barrier () from
/usr/lib64/libguile.so.17
#56 0x00002b9508ce96a3 in scm_i_with_guile_and_parent () from
/usr/lib64/libguile.so.17
#57 0x00002b9508cafe65 in scm_boot_guile () from /usr/lib64/libguile.so.17
#58 0x00000000004024ca in main (argc=1, argv=0x7fffa3343918) at gnucash-bin.c:512


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Add a new account anywhere in the account tree.
  
Actual results:
Crashes with above error.

Expected results:
Account added.

Additional info:
Comment 1 Brian Gerst 2006-05-27 09:31:30 EDT
This is for version 1.9.6-1, but I believe the problem actually started with
1.9.5-3.
Comment 2 Bill Nottingham 2006-08-07 13:28:22 EDT
Sorry about the delay. I just tried this on 2.0.1 on x86_64 and it works for me
- does this persist for you?
Comment 3 Brian Gerst 2006-08-07 19:02:04 EDT
I'm running gnucash-2.0.0-1.fc5 now and it's fixed.
Comment 4 Bill Nottingham 2006-08-07 19:33:07 EDT
Thanks! Closing.

Note You need to log in before you can comment on or make changes to this bug.