Bug 1933384 - localization, IndexError: list index out of range
Summary: localization, IndexError: list index out of range
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F34BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2021-02-27 01:00 UTC by Heðin
Modified: 2021-03-29 00:15 UTC (History)
9 users (show)

Fixed In Version: anaconda-34.24.5-3.fc34 anaconda-34.24.6-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-05 16:35:24 UTC
Type: Bug


Attachments (Terms of Use)
anaconda trackback (556.93 KB, text/plain)
2021-02-27 01:00 UTC, Heðin
no flags Details
xml of test-vm (5.65 KB, text/plain)
2021-02-27 13:19 UTC, Heðin
no flags Details

Description Heðin 2021-02-27 01:00:20 UTC
Created attachment 1759617 [details]
anaconda trackback

Description of problem:
Have tried to boot on both netinstall and workstation nightly iso and both fail to start anaconda

Version-Release number of selected component (if applicable):
f34 nightly 20210222 && 20210226

How reproducible:
100%

Steps to Reproduce:
1. Download nightly of 20210226
2. Boot with qemu on system with en_DK locales
3.

Actual results:
"An unknown error has occurred" during anaconda start.


Expected results:
Anaconda starts

Additional info:

Comment 1 Chris Murphy 2021-02-27 06:51:15 UTC
I tried German and can't reproduce it. Can you be more specific? The host is Fedora 33 Workstation? Using virt-manager or GNOME Boxes?

Comment 2 Chris Murphy 2021-02-27 06:58:58 UTC
    anaconda 34.24.5 exception report
    Traceback (most recent call first):
      File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 231, in initialize
        locale = localization.setup_locale(locales[0], self._l12_module)
      File "/usr/lib64/python3.9/site-packages/pyanaconda/ui/gui/__init__.py", line 737, in run
        self._currentAction.initialize()
      File "/sbin/anaconda", line 601, in <module>
        anaconda.intf.run()
    IndexError: list index out of range

Comment 3 Fedora Blocker Bugs Application 2021-02-27 07:00:37 UTC
Proposed as a Blocker for 34-beta by Fedora user chrismurphy using the blocker tracking app because:

 * The release must install and boot successfully as a virtual guest in a situation where the virtual host is running the current stable Fedora release. 
* The installer must run when launched normally from the release-blocking images. 
https://fedoraproject.org/wiki/Basic_Release_Criteria#Guest_on_current_stable_release

Comment 4 Heðin 2021-02-27 13:16:18 UTC
host is running:

$ cat /etc/fedora-release 
Fedora release 33 (Thirty Three)

$ uname -a
Linux theWorkstation 5.10.14-200.fc33.x86_64 #1 SMP Sun Feb 7 19:59:31 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

and I'm using virt-manager and qemu
$ dnf list installed qemu*
Installed Packages
qemu.x86_64                                          2:5.1.0-9.fc33                   @updates
qemu-audio-alsa.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-audio-oss.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-audio-pa.x86_64                                 2:5.1.0-9.fc33                   @updates
qemu-audio-sdl.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-block-curl.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-block-dmg.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-block-gluster.x86_64                            2:5.1.0-9.fc33                   @updates
qemu-block-iscsi.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-block-nfs.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-block-rbd.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-block-ssh.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-char-baum.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-common.x86_64                                   2:5.1.0-9.fc33                   @updates
qemu-device-display-qxl.x86_64                       2:5.1.0-9.fc33                   @updates
qemu-device-usb-redirect.x86_64                      2:5.1.0-9.fc33                   @updates
qemu-device-usb-smartcard.x86_64                     2:5.1.0-9.fc33                   @updates
qemu-guest-agent.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-img.x86_64                                      2:5.1.0-9.fc33                   @updates
qemu-kvm.x86_64                                      2:5.1.0-9.fc33                   @updates
qemu-kvm-core.x86_64                                 2:5.1.0-9.fc33                   @updates
qemu-system-aarch64.x86_64                           2:5.1.0-9.fc33                   @updates
qemu-system-aarch64-core.x86_64                      2:5.1.0-9.fc33                   @updates
qemu-system-alpha.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-alpha-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-arm.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-system-arm-core.x86_64                          2:5.1.0-9.fc33                   @updates
qemu-system-avr.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-system-avr-core.x86_64                          2:5.1.0-9.fc33                   @updates
qemu-system-cris.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-system-cris-core.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-lm32.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-system-lm32-core.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-m68k.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-system-m68k-core.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-microblaze.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-microblaze-core.x86_64                   2:5.1.0-9.fc33                   @updates
qemu-system-mips.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-system-mips-core.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-moxie.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-moxie-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-nios2.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-nios2-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-or1k.x86_64                              2:5.1.0-9.fc33                   @updates
qemu-system-or1k-core.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-ppc.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-system-ppc-core.x86_64                          2:5.1.0-9.fc33                   @updates
qemu-system-riscv.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-riscv-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-rx.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-system-rx-core.x86_64                           2:5.1.0-9.fc33                   @updates
qemu-system-s390x.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-s390x-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-sh4.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-system-sh4-core.x86_64                          2:5.1.0-9.fc33                   @updates
qemu-system-sparc.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-system-sparc-core.x86_64                        2:5.1.0-9.fc33                   @updates
qemu-system-tricore.x86_64                           2:5.1.0-9.fc33                   @updates
qemu-system-tricore-core.x86_64                      2:5.1.0-9.fc33                   @updates
qemu-system-unicore32.x86_64                         2:5.1.0-9.fc33                   @updates
qemu-system-unicore32-core.x86_64                    2:5.1.0-9.fc33                   @updates
qemu-system-x86.x86_64                               2:5.1.0-9.fc33                   @updates
qemu-system-x86-core.x86_64                          2:5.1.0-9.fc33                   @updates
qemu-system-xtensa.x86_64                            2:5.1.0-9.fc33                   @updates
qemu-system-xtensa-core.x86_64                       2:5.1.0-9.fc33                   @updates
qemu-ui-curses.x86_64                                2:5.1.0-9.fc33                   @updates
qemu-ui-gtk.x86_64                                   2:5.1.0-9.fc33                   @updates
qemu-ui-sdl.x86_64                                   2:5.1.0-9.fc33                   @updates
qemu-ui-spice-app.x86_64                             2:5.1.0-9.fc33                   @updates
qemu-user.x86_64                                     2:5.1.0-9.fc33                   @updates


I'm attaching the xml from the virtual machine.

Comment 5 Heðin 2021-02-27 13:19:48 UTC
Created attachment 1759646 [details]
xml of test-vm

Comment 6 Heðin 2021-02-27 13:21:39 UTC
More host settings

$ locale
LANG=en_DK.UTF-8
LC_CTYPE="en_DK.UTF-8"
LC_NUMERIC="en_DK.UTF-8"
LC_TIME="en_DK.UTF-8"
LC_COLLATE="en_DK.UTF-8"
LC_MONETARY="en_DK.UTF-8"
LC_MESSAGES="en_DK.UTF-8"
LC_PAPER="en_DK.UTF-8"
LC_NAME="en_DK.UTF-8"
LC_ADDRESS="en_DK.UTF-8"
LC_TELEPHONE="en_DK.UTF-8"
LC_MEASUREMENT="en_DK.UTF-8"
LC_IDENTIFICATION="en_DK.UTF-8"
LC_ALL=

$ localectl 
   System Locale: LANG=en_DK.UTF-8
       VC Keymap: dk-latin1
      X11 Layout: dk,fo
     X11 Variant: ,

Comment 7 Vendula Poncova 2021-03-01 11:03:28 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/3206

Comment 8 Lukas Ruzicka 2021-03-01 12:11:38 UTC
I could not reproduce this with Czech localisation, I will try the Danish, too.

Comment 9 Vendula Poncova 2021-03-01 13:07:57 UTC
Anaconda uses the geolocation results to set up the locale in this case, but the bug is reproducible with the boot option 'inst.lang=fo_FO'.

Comment 10 Geoffrey Marr 2021-03-01 16:52:42 UTC
The decision to classify this bug as an "AcceptedBlocker (Beta)" was made as it violates the following criterion:

"The installer must run when launched normally from the release-blocking images. "

See [0] for more details.

[0] https://pagure.io/fedora-qa/blocker-review/issue/258

Comment 11 Fedora Update System 2021-03-02 18:49:47 UTC
FEDORA-2021-24fafc1677 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-24fafc1677

Comment 12 Fedora Update System 2021-03-03 15:46:36 UTC
FEDORA-2021-24fafc1677 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-24fafc1677`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-24fafc1677

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Heðin 2021-03-04 23:59:43 UTC
I can confirm that the issue is resolved.

Tested by doing:
#1 download Fedora-Workstation-Live-x86_64-34-20210304.n.0.iso
#2 Apply sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-24fafc1677
#3 Start anaconda from the bottom bar

Result:
Anaconda starts up and after selecting relevant settings, the installation starts.

Comment 14 Fedora Update System 2021-03-05 16:35:24 UTC
FEDORA-2021-24fafc1677 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2021-03-22 17:53:30 UTC
FEDORA-2021-a12fa51168 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a12fa51168

Comment 16 Fedora Update System 2021-03-23 02:01:38 UTC
FEDORA-2021-a12fa51168 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a12fa51168`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a12fa51168

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2021-03-29 00:15:27 UTC
FEDORA-2021-a12fa51168 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.