Bug 1933666 - Getting Forbidden for image in a container template when creating a sample app
Summary: Getting Forbidden for image in a container template when creating a sample app
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.z
Assignee: Christoph Jerolimov
QA Contact: Gajanan More
Harsh Mishra
URL:
Whiteboard:
: 1921717 (view as bug list)
Depends On: 1933665
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-01 11:19 UTC by Christoph Jerolimov
Modified: 2021-06-10 09:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
While creating a sample application, the *Developer* perspective creates multiple resources that depend on each other and must be completed in a specific order. Previously, the admission plug-in sometimes could not check one of these resources, preventing the *Developer* perspective from generating the sample application. This issue has been fixed. The code creates the resources in the required order, so creating a sample application is more stable.
Clone Of:
Environment:
Last Closed: 2021-05-12 12:18:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 8261 0 None open Bug 1933666: [release-4.6] Create ImageStream and other resources for samples step by step 2021-03-29 11:24:54 UTC
Red Hat Product Errata RHBA-2021:1487 0 None None None 2021-05-12 12:18:29 UTC

Description Christoph Jerolimov 2021-03-01 11:19:39 UTC
Description of problem:
When creating a new Node.js app (I hit the same problem also with the Go app) in the Dev Sandbox, I sometimes get an error:

Error "Forbidden: this image is prohibited by policy: this image is prohibited by policy (changed after admission)" for field "spec.template.spec.containers[0].image".

Version-Release number of selected component (if applicable):
4.6-4.8

How reproducible:
Intermittent

Steps to Reproduce:
1. Go to Add -> Samples
2. Choose either Go or Node.js app
3. Click on create

Actual results:
Error message above was shown sometimes when creating a sample app.

Expected results:
Apps get created without showing any error.

Additional info:
This is a copy of Jira issue https://issues.redhat.com/browse/ODC-5468

Comment 1 Christoph Jerolimov 2021-04-06 22:14:55 UTC
*** Bug 1921717 has been marked as a duplicate of this bug. ***

Comment 2 Christoph Jerolimov 2021-04-30 06:11:08 UTC
Increase severity as this fixes also the high prio, high severity issue https://bugzilla.redhat.com/show_bug.cgi?id=1921717

Comment 5 Gajanan More 2021-05-04 05:49:08 UTC
I verified the bugzilla on:
Build: 4.6.0-0.nightly-2021-05-03-000315
Browser: Google Chrome Version 89
Marking this as verified

Comment 7 errata-xmlrpc 2021-05-12 12:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.28 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1487


Note You need to log in before you can comment on or make changes to this bug.