Bug 1933742 - Firefox fails to build on ppc64le - error: use of undeclared identifier '__ieee128'
Summary: Firefox fails to build on ppc64le - error: use of undeclared identifier '__ie...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: ppc64le
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1934065
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2021-03-01 15:32 UTC by Martin Stransky
Modified: 2021-04-06 08:37 UTC (History)
12 users (show)

Fixed In Version: firefox-87.0-4.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-06 08:37:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Stransky 2021-03-01 15:32:17 UTC
Description of problem:

Firefox fails to build on ppc64le:

error: failed to run custom build command for `neqo-crypto v0.4.19 (https://github.com/mozilla/neqo?tag=v0.4.19#7bed9666)`
Caused by:
  process didn't exit successfully: `/builddir/build/BUILD/firefox-86.0/objdir/netwerk/test/http3server/./release/build/neqo-crypto-63b9fc0afae8a572/build-script-build` (exit code: 101)
  --- stdout
  cargo:rustc-link-lib=dylib=nssutil3
  cargo:rustc-link-lib=dylib=nss3
  cargo:rustc-link-lib=dylib=ssl3
  cargo:rustc-link-lib=dylib=plds4
  cargo:rustc-link-lib=dylib=plc4
  cargo:rustc-link-lib=dylib=nspr4
  cargo:rustc-link-search=native=/builddir/build/BUILD/firefox-86.0/objdir/dist/bin
  cargo:rustc-link-search=native=/builddir/build/BUILD/firefox-86.0/objdir/security/nss/lib/nss/nss_nss3
  cargo:rustc-link-search=native=/builddir/build/BUILD/firefox-86.0/objdir/security/nss/lib/ssl/ssl_ssl3
  cargo:rustc-link-search=native=/builddir/build/BUILD/firefox-86.0/objdir/config/external/nspr/pr
  cargo:rerun-if-changed=/builddir/build/BUILD/firefox-86.0/objdir/netwerk/socket/neqo/extra-bindgen-flags
  cargo:rerun-if-changed=bindings/bindings.toml
  cargo:rerun-if-changed=bindings/nss_init.h
  cargo:rerun-if-changed=bindings/mozpkix.hpp
  --- stderr
  clang version 12.0.0 (Fedora 12.0.0-0.1.rc1.fc35)
  Target: powerpc64le-unknown-linux-gnu
  Thread model: posix
  InstalledDir:
  Found candidate GCC installation: /../lib/gcc/ppc64le-redhat-linux/11
  Found candidate GCC installation: /usr/lib/gcc/ppc64le-redhat-linux/11
  Selected GCC installation: /usr/lib/gcc/ppc64le-redhat-linux/11
  Candidate multilib: .;@m64
  Selected multilib: .;@m64
  ignoring nonexistent directory "lib64/clang/12.0.0/include/ppc_wrappers"
  ignoring nonexistent directory "lib64/clang/12.0.0/include"
  ignoring nonexistent directory "/include"
  ignoring duplicate directory "/usr/include/nspr4"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ppc64le-redhat-linux"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/backward"
  ignoring duplicate directory "/usr/local/include"
  ignoring duplicate directory "/usr/include"
  #include "..." search starts here:
  #include <...> search starts here:
   /usr/include/nspr4
   /usr/include/nss3
   /builddir/build/BUILD/firefox-86.0/objdir/dist/include/nss
   /builddir/build/BUILD/firefox-86.0/objdir/dist/include/cairo
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ppc64le-redhat-linux
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/backward
   /usr/lib64/clang/12.0.0/include/ppc_wrappers
   /usr/local/include
   /usr/lib64/clang/12.0.0/include
   /usr/include
  End of search list.
  Failed to run rustfmt: No such file or directory (os error 2) (non-fatal, continuing)
  clang version 12.0.0 (Fedora 12.0.0-0.1.rc1.fc35)
  Target: powerpc64le-unknown-linux-gnu
  Thread model: posix
  InstalledDir:
  Found candidate GCC installation: /../lib/gcc/ppc64le-redhat-linux/11
  Found candidate GCC installation: /usr/lib/gcc/ppc64le-redhat-linux/11
  Selected GCC installation: /usr/lib/gcc/ppc64le-redhat-linux/11
  Candidate multilib: .;@m64
  Selected multilib: .;@m64
  ignoring nonexistent directory "lib64/clang/12.0.0/include/ppc_wrappers"
  ignoring nonexistent directory "lib64/clang/12.0.0/include"
  ignoring nonexistent directory "/include"
  ignoring duplicate directory "/usr/include/nspr4"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ppc64le-redhat-linux"
  ignoring duplicate directory "/usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/backward"
  ignoring duplicate directory "/usr/local/include"
  ignoring duplicate directory "/usr/include"
  #include "..." search starts here:
  #include <...> search starts here:
   /usr/include/nspr4
   /usr/include/nss3
   /builddir/build/BUILD/firefox-86.0/objdir/dist/include/nss
   /builddir/build/BUILD/firefox-86.0/objdir/dist/include/cairo
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ppc64le-redhat-linux
   /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/backward
   /usr/lib64/clang/12.0.0/include/ppc_wrappers
   /usr/local/include
   /usr/lib64/clang/12.0.0/include
   /usr/include
  End of search list.
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:222:38: error: use of undeclared identifier '__ieee128'
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:230:29: error: use of undeclared identifier '__ieee128'
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:231:40: error: use of undeclared identifier '__ieee128'
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:222:38: error: use of undeclared identifier '__ieee128', err: true
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:230:29: error: use of undeclared identifier '__ieee128', err: true
  /usr/lib/gcc/ppc64le-redhat-linux/11/../../../../include/c++/11/ext/numeric_traits.h:231:40: error: use of undeclared identifier '__ieee128', err: true
  thread 'main' panicked at 'unable to generate bindings: ()', /builddir/build/BUILD/firefox-86.0/third_party/rust/neqo-crypto/build.rs:281:39
  stack backtrace:
     0:        0x13b0ede14 - <std::sys_common::backtrace::_print::DisplayBacktrace as core::fmt::Display>::fmt::h23490cf324746195
     1:        0x13b13e9c4 - core::fmt::write::ha6de4827804b0a5d
     2:        0x13b0ecf68 - std::io::Write::write_fmt::hf3215b91c3110139
     3:        0x13b105438 - std::panicking::default_hook::{{closure}}::h94682851f3697be9
     4:        0x13b104eac - std::panicking::default_hook::h5deafae168c01ca9
     5:        0x13b105dfc - std::panicking::rust_panic_with_hook::ha0b6b36abff7dc8f
     6:        0x13b0eead8 - std::panicking::begin_panic_handler::{{closure}}::hdbfd9c82051f9380
     7:        0x13b0edfd0 - std::sys_common::backtrace::__rust_end_short_backtrace::h004befdb61d9ed00
     8:        0x13b105754 - rust_begin_unwind
     9:        0x13b13b79c - core::panicking::panic_fmt::h7b9d5075bf0d5cbb
    10:        0x13b13b830 - core::result::unwrap_failed::h2a5dd563c13ba863
    11:        0x13ad11820 - core::result::Result<T,E>::expect::hfd7f4ab63f7d533a
    12:        0x13ad1307c - build_script_build::build_bindings::h185b2166e78202ed
    13:        0x13ad13f10 - build_script_build::main::hb4025d0378c50759
    14:        0x13ad0ebe4 - core::ops::function::FnOnce::call_once::h6e9127d4fb19e763
    15:        0x13ad0ea08 - std::sys_common::backtrace::__rust_begin_short_backtrace::h389c2b039423f8db
    16:        0x13ad0e42c - std::rt::lang_start::{{closure}}::hbf61a3491f9ad666
    17:        0x13b106264 - std::rt::lang_start_internal::h529c07d8c88346f4
    18:        0x13ad0e3f0 - std::rt::lang_start::h29c08d119371b5e9
    19:        0x13ad14268 - main
    20:     0x7fffad670454 - generic_start_main.constprop.0.isra.0
    21:     0x7fffad670640 - __libc_start_main
    22:                0x0 - <unknown>
gmake[4]: *** [/builddir/build/BUILD/firefox-86.0/config/makefiles/rust.mk:393: force-cargo-program-build] Error 101
gmake[3]: *** [/builddir/build/BUILD/firefox-86.0/config/recurse.mk:72: netwerk/test/http3server/target] Error 2
gmake[3]: *** Waiting for unfinished jobs....

Comment 1 Martin Stransky 2021-03-01 15:33:47 UTC
Build log:
https://kojipkgs.fedoraproject.org//work/tasks/7290/62877290/build.log

Comment 2 Dan Horák 2021-03-01 15:36:09 UTC
I have seen the same error when building ghdl in rawhide, it seems to be related to LLVM 12.

Comment 3 Dan Horák 2021-03-02 12:31:45 UTC
I have filed a separate clang issue as bug 1934065

Comment 4 Martin Stransky 2021-03-13 15:31:58 UTC
This one affects Fedora 34 too:
https://koji.fedoraproject.org/koji/taskinfo?taskID=63648849

Comment 5 Dan Horák 2021-03-16 10:49:46 UTC
A fix got accepted to llvm/clang, so we should get a new build soon to unblock Firefox ...

Comment 6 Dan Horák 2021-04-06 08:37:10 UTC
starting with firefox-87.0-4 the ppc64le builds work again


Note You need to log in before you can comment on or make changes to this bug.