Bug 1933752 - Lots of conjunction warnings in ovn-controller container logs
Summary: Lots of conjunction warnings in ovn-controller container logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: 4.6.z
Assignee: Andrew Stoycos
QA Contact: Kedar Kulkarni
URL:
Whiteboard:
Depends On: 1934218
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-01 16:02 UTC by Jonas Nordell
Modified: 2021-04-13 18:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1949237 (view as bug list)
Environment:
Last Closed: 2021-03-30 17:03:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 455 0 None closed Bug 1933752: Bump to ovn2.13-20.09.0-7.el8fdn 2021-03-17 11:58:56 UTC
Red Hat Knowledge Base (Solution) 5842861 0 None None None 2021-03-01 16:03:36 UTC
Red Hat Product Errata RHBA-2021:0952 0 None None None 2021-03-30 17:03:24 UTC

Description Jonas Nordell 2021-03-01 16:02:15 UTC
Description of problem:

Many (Not all) ovnkube-node-<id>/ovn-controller containers logs a lot of errors like this:

2021-03-01T13:53:49.448605634Z 2021-03-01T13:53:49Z|365512|ofp_actions|WARN|"conjunction" actions may be used along with "note" but not any other kind of action (such as the "set_field" action used here)
2021-03-01T13:53:49.448605634Z 2021-03-01T13:53:49Z|365513|ofctrl|INFO|OpenFlow error: OFPT_ERROR (OF1.5) (xid=0x2c2b96): NXBAC_BAD_CONJUNCTION
2021-03-01T13:53:49.448605634Z OFPT_FLOW_MOD (OF1.5) (xid=0x2c2b96): ***decode error: NXBAC_BAD_CONJUNCTION***
2021-03-01T13:53:49.448605634Z 00000000  06 0e c8 58 00 2c 2b 96-00 00 00 00 00 00 00 00 |...X.,+.........|
2021-03-01T13:53:49.448605634Z 00000010  00 00 00 00 00 00 00 00-2c 02 00 00 00 00 07 d1 |........,.......|

Also observed in ovs-node-<id>/ovs-daemons container 

2021-03-01T13:53:55.655987139Z 2021-03-01T13:53:55.655Z|385742|connmgr|INFO|Dropped 19 log messages in last 6 seconds (most recently, 1 seconds ago) due to excessive rate
2021-03-01T13:53:55.655987139Z 2021-03-01T13:53:55.655Z|385743|connmgr|INFO|br-int<->unix#0: sending NXBAC_BAD_CONJUNCTION error reply to OFPT_FLOW_MOD message
2021-03-01T13:53:55.658734434Z 2021-03-01T13:53:55.657Z|385744|ofp_actions|WARN|"conjunction" actions may be used along with "note" but not any other kind of action (such as the "set_field" action used here)

Version-Release number of selected component (if applicable):
OCP 4.6.15
OSP 16.1

How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
Seems to be similar to https://bugzilla.redhat.com/show_bug.cgi?id=1840556

Comment 2 Dan Williams 2021-03-01 16:35:52 UTC
Probably a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1871931 which was fixed in ovn2.13-20.09.0-4 and later, while 4.6 only has -1.

Comment 10 Kedar Kulkarni 2021-03-22 15:38:56 UTC
I tested this on OpenShift 4.6.22 - ovn cluster: 

# oc get clusterversion version -o jsonpath="{.status.desired.version}"                   
4.6.22

Checking the OVN versions, found following:

ovn2.13-20.09.0-7.el8fdn.x86_64
ovn2.13-host-20.09.0-7.el8fdn.x86_64
ovn2.13-central-20.09.0-7.el8fdn.x86_64
ovn2.13-vtep-20.09.0-7.el8fdn.x86_64

This matches the fix that was merged.

Also checked logs for all ovn pods and saw no mention of "Conjunction" warnings.

Thanks.

Comment 12 errata-xmlrpc 2021-03-30 17:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0952


Note You need to log in before you can comment on or make changes to this bug.