This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 19338 - kdeinit fails for non Mesa GL drivers!
kdeinit fails for non Mesa GL drivers!
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kde2libs (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 16:55 EDT by Sammy
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 13:05:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2000-10-18 16:55:47 EDT
For systems that use other acceleratet GL drivers (like NVIDIA)
kdeinit crashes because there is a call that is MESA specific.
Here is the message:

kdeinit: error while loading shared libraries:
/usr/lib/qt-2.2.1/lib/libqt.so.2: undefined symbol: glXCreateGLXPixmapMESA
QSocketNotifier: Multiple socket notifiers for same socket 9 and type read

I am not sure where exactly the error is but it essentially prevents
the use of kde2.
Comment 1 Bernhard Rosenkraenzer 2000-11-16 06:54:23 EST
This is not a bug - we don't support non-Mesa drivers.

However, it should work with Qt 2.2.2.

Note You need to log in before you can comment on or make changes to this bug.