Bug 19339 - A MESA specific call
A MESA specific call
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: qt (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 16:58 EDT by Sammy
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 16:58:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2000-10-18 16:58:31 EDT
In qt-2.2.1 there seems to be a MESA specific call that crashes
kde-2.0-rc2 kdeinit. here is the error message:

kdeinit: error while loading shared libraries:
/usr/lib/qt-2.2.1/lib/libqt.so.2: undefined symbol: glXCreateGLXPixmapMESA
QSocketNotifier: Multiple socket notifiers for same socket 9 and type read

People who use non-mesa accelerated GL drivers will experience this
problem and could not use kde-2.
Comment 1 Bernhard Rosenkraenzer 2000-10-20 10:06:24 EDT
There's no way to fix this without breaking support for the normal (Mesa) driver without severe changes to Qt.

Recompiling the package should fix the problem for you, however, there's nothing we can do to build a binary package that can handle both.
(We aren't shipping any non-Mesa drivers anyway).

Note You need to log in before you can comment on or make changes to this bug.