Bug 193394 - Anaconda fails to install packages on DVD using the GUI
Anaconda fails to install packages on DVD using the GUI
Status: CLOSED DUPLICATE of bug 165332
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-27 18:41 EDT by Mr. Mizzen
Modified: 2013-01-09 20:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 15:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum listing of packages Anaconda failed to install from DVD (30.75 KB, text/plain)
2006-05-27 18:41 EDT, Mr. Mizzen
no flags Details

  None (edit)
Description Mr. Mizzen 2006-05-27 18:41:06 EDT
Description of problem:
Packages included in the core DVD are never installed by Anaconda
regardless of menu selections.
The problem was first noticed in that anaconda-runtime never installs from DVD
even though the package rpm is on the DVD.
The second package that never installs was switchdesk-gui.noarch                    

Version-Release number of selected component (if applicable):
all

How reproducible:
Vey easy to reproduce


Steps to Reproduce:
1. Use the GUI and select every possible box including all languages
2. Complete a full FC5 install, then run #yum list available
3.View the yum listing to see every package Anaconda failed to install from core
  
Actual results:
It looks like there are roughly 457 packages Anaconda fails to install
from the DVD.

Expected results:
After the install, every possible package on the DVD should have been installed
and running yum list available should come up with nothing other than
updates or extras.

Additional info:
At least part of the problem looks like it is comes from the comps.xml file.
No where in that file does it call for the Anaconda packages.
I have not checked all 457 listed packages against the comps.xml file, but
a good guess is they failed to be included (like anaconda runtime pkg) thus
Anaconda never knows to install them.

Overall this is a problem any time an install is done when there is no internet
connection. By default, yum is primarily an online utility and never looks at
the DVD as a repository. The package manager GUI will not even come up if
offline and yum does not function well if offline either.
This leaves you with a manual only install for each and every package you need.

Missing package list from "yum list available" attached: 

If this is missing info from the comps.xml file AND if someone can provide me
with an updated comps.xml, I can create new DVD's with it and test the results.
Comment 1 Mr. Mizzen 2006-05-27 18:41:07 EDT
Created attachment 130120 [details]
yum listing of packages Anaconda failed to install from DVD
Comment 2 Chris Lumens 2006-06-02 13:18:02 EDT
The comps file does not contain every single package, so that is a problem with
that package.  In the future, pup is supposed to support CDs and DVDs as a
repository so you will be able to use your install media within that tool like
you describe.  Moving to comps for now.
Comment 3 Mr. Mizzen 2006-06-03 06:30:29 EDT
(In reply to comment #2)
> The comps file does not contain every single package, so that is a problem with
> that package.  In the future, pup is supposed to support CDs and DVDs as a
> repository so you will be able to use your install media within that tool like
> you describe.  Moving to comps for now.

Chris,
Thanks for the comment / reply. However I think I failed to make my points
specific enough.
Let me be a bit more verbose with my verbiage.

The bug / problem with the comps file is actually several parts.
Some packages like Anaconda and Anaconda-Utils are just never called for in comps. 
This is an omission.


Some are like the problem with Ruby.
ruby-docs.i386, ruby-irb.i386, ruby-rdoc.i386, ruby-ri.i386 and ruby-tcltk.i386
are on the core DVD.
In the comps file, Ruby is listed as such:
<default>false</default>
    <uservisible>false</uservisible>
    <packagelist>
      <packagereq type="mandatory">ruby</packagereq>
      <packagereq type="default">ruby-devel</packagereq>
      <packagereq type="default">ruby-mode</packagereq>
      <packagereq type="optional">eruby</packagereq>
      <packagereq type="optional">ri</packagereq>
    </packagelist>
  </group>
Because <uservisible>false</uservisible> is FALSE, the list can not be viewed
when installing.
This is a BUG because several packages are listed as OPTIONAL. 
How can anyone select the options of Ruby when they can not see them displayed?

For Ruby I see 3 possible fixes.
1)	Change <uservisible>false</uservisible> to TRUE and make sure all packages
are listed.
2)	Leave <uservisible>false</uservisible> as FALSE, but change the packages to
DEFAULT and make sure they are all listed.
3)	Coordinate with RUBY to have their RPMs call as dependencies any packages
that should not be separately listed.

There are also a number of language dependant issues to deal with.
For example, xorg-x11-fonts-ISO8859-2-75dpi.noarch never gets installed. 
I happen to need iso8859-2 because I use Hungarian. 8859-2 is used for most
Central / East European languages.
As comps is now, even though I selected all languages (including Hungarian) for
the test, and I included xorg support, xorg-x11-fonts-ISO8859-14-100dpi.noarch,
xorg-x11-fonts-ISO8859-14-75dpi.noarch, xorg-x11-fonts-ISO8859-15-100dpi.noarch,
xorg-x11-fonts-ISO8859-15-75dpi.noarch, xorg-x11-fonts-ISO8859-2-100dpi.noarch,
xorg-x11-fonts-ISO8859-2-75dpi.noarch, xorg-x11-fonts-ethiopic.noarch and
xorg-x11-fonts-syriac.noarch 
are never installed.
Of course FC5 might not have too many Ethiopian or Syrian language users, so
this might have gone un-noticed by them :-)

The primary point is, each item or group of items in the omission list has some
basic reasons for failing to install or being available. 
Most of those reasons revolve around the comps.xml file although some might
better be resolved by the core packages calling for the dependencies.
Each group on the omissions list needs to be reviewed.

Over time I can manually correct the comps.xml file and I could submit a working
copy.
However, from a quality and development point, that does not properly address
“Cause and corrective action”. 
The cause of these omissions and the corrective action to ensure this does not
show up in a future release is NOT solved by me or anyone else just hand coding
the file. 

There of course is the possibility that I misunderstand the reason for having
hundreds of rpm files in a distribution iso that never get installed. 
My assumption is, they should:
Either be available for installation – or have the proper relationship dependencies
Or
They should be omitted from Core and many of the popular and useful things from
extras (such as all the Yum packages) should be substituted.
Am I missing some logic or reasons here?

Comment 4 Jesse Keating 2006-06-22 15:42:57 EDT

*** This bug has been marked as a duplicate of 165332 ***

Note You need to log in before you can comment on or make changes to this bug.