Bug 19345 - Option --add does not add
Option --add does not add
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.3
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-18 17:10 EDT by Michal Jaegermann
Modified: 2014-03-16 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-18 17:18:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2000-10-18 17:10:29 EDT
Is this a bug or a misguided intention?

# chkconfig --list nfs
nfs             0:off   1:off   2:off   3:off   4:off   5:off   6:off
# chkconfig --add nfs 
# chkconfig --list nfs
nfs             0:off   1:off   2:off   3:off   4:off   5:off   6:off

I know that I can do 'chkconfig --level 345 nfs on' and this will work
but a documentation is far from clear on these points.

The same goes for various other services.

  Michal
  michal@harddata.com
Comment 1 Cristian Gafton 2000-10-18 17:18:38 EDT
I have verified this to be the case with the latest internal build of the
package. The reason it is doing this is because of some missing information in
the init script

/etc/init.d/nfs

- # chkconfig: - 60 20
+ # chkconfig: 345 60 20

This may this wayfor a reason that I am not aware of but that is why chkconfig
does not add and del properly.

Changing component to nfs-utils and arch to Alpha since I assume by this bug
being against RC1 is the proper arch.
Comment 2 Bill Nottingham 2000-10-18 19:19:34 EDT
Um, that's the proper behavior.

--add just adds the links in the default state (in this case, disabled
in all runlevels.)

The --level 345 on is the correct way to activate it.

Note You need to log in before you can comment on or make changes to this bug.