Bug 193454 - No .so lib
No .so lib
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lua (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael J Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-28 23:05 EDT by Ian Chapman
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 17:39:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Chapman 2006-05-28 23:05:11 EDT
Description of problem:
The lua rpm doesn't contain a shared library, it only contains lib archive (.a)

Version-Release number of selected component (if applicable):
lua-5.1-2.fc4

How reproducible:


Steps to Reproduce:
1. 
2.
3.
  
Actual results:


Expected results:


Additional info:
A new package called cegui "bug 193342" will eventually be linked with it.
Comment 1 Hans de Goede 2006-05-29 01:50:36 EDT
Ok,

I think this warrants some more explanation, I'm the reviewer for bug 193342 and
such have requesed the creation of this "bug".

cegui (the lib being packaged in bug 193342) comes with its own private copy of
lua (and tolua++ and pcre). Since having private copies of libs in packages is
concidered bad practice I asked the packager to use the system pcre instead of
the private copy. He responded that the same then probably applied to lua, but
that lua didn't have a .so to link against.

Which brings us here, even though it is still advantagous to use the system lua
(crreating one central place for bugfixes) as is, it would be better if the
system lua would offer a .so to use. Because now each time a serious bug in lua
is fixed all packages linking against it must be rebuild to pick up the fix.

Hence this RFE (request for enhancement). If you're willing to apply a patch to
offer a .so, but have trouble creating such a patch yourself let me know and
I'll try to create such a patch myself.
Comment 2 Michael J Knox 2006-05-29 01:55:52 EDT
There will be a new lua on the repos tomorrow hopefully. Fixing it in 5.1-3,
sorry I missed it. 
Comment 3 Hans de Goede 2006-05-29 02:03:52 EDT
Cool!

And no problem, thanks for the quick fix!

Note You need to log in before you can comment on or make changes to this bug.