Bug 193456 - modprobe cannot remove modules that have been renamed
modprobe cannot remove modules that have been renamed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: module-init-tools (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 01:30 EDT by Brian Carp
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 12:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Carp 2006-05-29 01:30:31 EDT
Description of problem: If you rename a module while it is being inserted into
the kernel, a subsequent call to 'modprobe -r' will fail with a FATAL error,
although the module can be removed successfully under its new name with rmmod. 
This is also relevant in modprobe.conf with 'install' and 'remove' commands.

How reproducible: Always

Steps to Reproduce:
1. /sbin/modprobe -o some-alias some-module
2. /sbin/modprobe -r some-alias
3. /sbin/rmmod some-alias
  
Actual results: Step #2 fails with a FATAL error where step #3 succeeds.

Expected results: Step #2 should result in the same behavior as step #3.
Comment 3 Jon Masters 2006-10-12 18:28:59 EDT
I will add this to the TODO for upstream.
Comment 6 Jon Masters 2007-03-22 12:11:39 EDT
Actually, now I'm inclined to say this is *not* a bug.

modprobe -o is intended for module testing, temporarily renaming a module.
modprobe uses the modules.dep file for name tracking, so you end up having to
use rmmod directly if you rename the modules in this way - which actually will
fail in future since the key signature check will balk on the rename too.

Can you give me an example of a situation where this is causing a problem? other
than renaming on the command line?

Jon.

Note You need to log in before you can comment on or make changes to this bug.