Bug 19346 - anaconda fails at end of copying packages to HD. Trace included.
anaconda fails at end of copying packages to HD. Trace included.
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-10-18 17:31 EDT by Greg Vilardi
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-15 11:54:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg Vilardi 2000-10-18 17:31:02 EDT
Attempting to install RH 7.0 on Dell Dimension XPS B933r with Promise Ultra100 and IBM 45GB disk. Install was attempted using boot disk 
that supports controller correctly and anaconda suppliment in the update-disk-20001009.img. Machine is going to be tri-boot, W95, NT4.0 
Server (not domain controller) and RH7. W95 and NT are successfully installed. Disk is partitioned with 2 FAT16 2GB partitions, 1 NTFS 4GB 
partition and rest for linux. Partitions are laid with 2GB root, 512MB swap, and a couple of spare 10GB ext2fs partitions.  The install was 
attempted by entering "linux updates expert text" at the first prompt, and it was attempted as a custom system, selecting individual packages. 
The error dialog box appears at the end of or just after the system finishes transferring install files to the hard disk.

I checked all of the unique bugs for anaconda and did not see this trace back in any of them.

The trace back appears below:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
  intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
    if todo.doInstall ():
  File "/tmp/updates/todo.py", line 1499, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 63, in systemMounted
    isys.lochangefd("/tmp/loop", self.loopbackFile)
  File "/usr/lib/anaconda/isys.py", line 55, in lochangefd
    _isys.lochangefd(loop, targ)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
file: /mnt/sysimage//rhinstall-stage2.img
loop: 11
targ: 12
device: /tmp/loop

ToDo object:

Comment 1 Brent Fox 2000-10-23 14:39:32 EDT
Can you provide any information about which packages you were installing?  Also,
was this a CD-based install or something else?
Comment 2 Greg Vilardi 2000-10-23 18:15:34 EDT
This was installed from a CD rom that was burned by a friend of mine who used it to upgrade from one of the RedHat  7.0 beta versions. The CDs were 
the original ISO's that were released by RedHat.  The system does not get to create an install.log, so I can't give you a list of packages. I am doing some 
fairly heavy customization of the set, and at the end, I do choose to fulfill all of the dependencies. I'm going for a hobyist/professional unix 
applications developer set of utilities. games, all development tools, mostly default libraries, default multimedia stuff, no tftp, talk, news, elm, etc. I'm 
opting for gnome over KDE. Most of the documentation is requested. I also removed the isdn stuff, and didn't install any other network transport except 
tcp/ip. If you want any alternate console info to pinpoint this better, please let me know. I'm trying a default server install as I write this to see if I can get it 
that to work, but I have limited hope.
Comment 3 Brent Fox 2000-10-24 11:15:50 EDT
If you can get a copy of Red Hat Linux 7, I would encourage you to try it and
see if the problem still exists.  It is possible that this was fixed during the
beta cycle.
Comment 4 Greg Vilardi 2000-10-24 11:36:38 EDT
The CD rom was the original release of Red Hat 7.0 from the ISO. Are you suggesting that I get the current CD images? Are there any other changes to 
anaconda that are not included in the update disk that I referenced above? I will be happy to ask my friend to burn the new CDs, but I'd like some 
indication that there have been some changes that might make a difference over the process I currently am using.

The bug (if one exists) is clearly in the custom system installation portion, since the standard server installation went Ok. However I will now need to sink 
many hours into customizing the system that I otherwise wouldn't. Once I get a working kernel for this machine, I'll archive the source and try to install 
Workstation to see if it gets me closer to a useful system.
Comment 5 Brent Fox 2000-10-27 12:49:05 EDT
I misunderstood...I thought you were using the beta cd's.
Comment 6 Michael Fulbright 2000-11-17 15:11:59 EST
Passing to QA to reproduce.
Comment 7 Need Real Name 2000-12-21 12:07:25 EST
Reproduced on a Dell Dimension L667r, with two Maxtor drives (hda = 10GB,
WIndows Me; hdd = 46GB). Assigned hdd -> /boot, /, /home, swap expecting a
"Cannot boot from secondary slave drive" error, but install proceeded. Chose
standard workstation install. Ananconda crashes while reading packages from
RedHat 7.0
CD 1. 

Retried with text-mode install - crashes at same point with identical error.

Dump of error message follows: ---------------------------------
--- anacdump.txt ---

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line 
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getComp
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in readCom
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCo
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __geti
    return self.packages[item]
 KeyError: basesystem

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 82c0b68>
item: basesystem

ToDo object:


Comment 8 Brock Organ 2001-01-09 15:39:57 EST
we are not seeing these problems with similar hardware in test ... can you
verify that your cd images are correct via md5sum ...?

Comment 9 Greg Vilardi 2001-01-10 18:58:06 EST
The CD matches the image that it was burned from. I checked that the md5 sums
were accurate when the CD's were burned.
Comment 10 Need Real Name 2001-01-26 15:36:10 EST
Update to my comment on 20 December 2001:

Disconnected the first hard drive, so that the new machine configuration was
a Dell Dimension L667r, with one Maxtor drive (hda = 46GB, pre-partitioned with
Partition Magic). 

Tried RedHat 7.0 with anaconda updates disk (boot: linux updates) and asked to
format /boot and / during install. Install crashes with identical error as
before, however, it adds a line "No free space left on device" before crashing.
I selected <1 GB of packages on a 3 GB / partition (46 GB disk), and asked for a
reformat of that partition.

Also tried: "boot: linux" (no updates) - identical crash as before.
Also tried RedHat 6.2 "boot: linux" and got the exact same crash.
Comment 11 Motrex Systems - System Administrators 2001-02-08 07:38:04 EST
I too am trying to install RED HAT V70. If I boot from install disk (with ' 
upgrades'fix image) I can reproduce the SAME ERROR every time - It is 
formatting ready for package installation and fails to MOUNT a partition.
The trace back code is back at work but it appears to follow the above error 
and fails around the "line 1030" code mark.
I also produced the same error in V6.1 that I have a CD for.
I will add the traceback code in an extension of these comments tomorrow.
Comment 12 Motrex Systems - System Administrators 2001-02-08 07:45:32 EST
Missing info - ONLY does it if you choose 'expert' for a Workstation install ;
- The system is an old IBM 75 Mhz Pentium
- The hard drive is a Seagate 1.7Gb (worked fine before !!)
- Anaconda crashes on formatting a partition (pick one) still using CD no.1
Comment 13 Need Real Name 2001-02-11 04:07:16 EST
I have the same Problem on a AMD Athlon 750 with 20GB IBM Harddisk.
Comment 14 Brock Organ 2001-02-14 17:47:48 EST
we have not been able to reproduce this problem in our test lab using similar
(NOT identical! :( ) hardware, so haven't been able to advance on this issue ...
(if applicable:) Do you still have the same problem using our recent public beta
(fisher) ...?
Comment 15 Brock Organ 2001-02-14 17:52:05 EST
I ask as we have added more general error checking to the installer to try and
handle these issues better (more gracefully, more descriptive of errors, etc.)
Comment 16 Michael Fulbright 2001-03-14 12:58:18 EST
Closing due to inactivity. Please reopen if you have additional information to add.

Note You need to log in before you can comment on or make changes to this bug.