Bug 19347 - Missing stuff under Tools/scripts/
Summary: Missing stuff under Tools/scripts/
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 22:13 UTC by Enrico Scholz
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 20:19:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-10-18 22:13:04 UTC
Please include scripts under Tools/scripts/, because there is a lot of
stuff needed or being usefully for the work with python. E.g. the Python
Library Reference says at  `8.12 fcntl...':

| You can create the modules yourself with the h2py script,
| found in the Tools/scripts/ directory

Comment 1 Mihai Ibanescu 2004-07-29 23:17:10 UTC
Wow this is an old one.
Arbitrarily chose to deploy the scripts under
/usr/share/python2.3/Tools/scripts/*py

Does that make sense? I can change it if not...

Comment 2 Mihai Ibanescu 2004-07-29 23:42:10 UTC
python 2.3.4-5 will have this fixed.

Comment 3 Jeff Pitman 2004-08-12 15:55:28 UTC
I've browsed both Debian lists and Python-dev.  I 
think /usr/lib/python2.3/Tools was the eventual consensus.  But, I 
don't know.  I'd rather see if another precedent has been set before 
making a plunge into /usr/share.  I'll troll around some other 
distros to see... 

Comment 4 Mihai Ibanescu 2004-08-13 17:56:03 UTC
Jeff, thanks for your help. Please move the bug back to ASSIGNED if my
choice was not appropriate.

Comment 5 Jeff Pitman 2004-08-15 08:24:02 UTC
Here's the lowdown: 
 
Official Python RPM SPEC (Sean's) puts the files 
in /usr/lib/pythonX.Y/Tools. 
Turbo Linux puts the files in /usr/lib/pythonX.Y/Tools. 
Engarde linux also put them in /usr/lib/pythonX.Y/Tools. 
 
Everyone else either does it how Redhat used to or they don't even 
package anything from Tools altogether.  Suse just packages idle in 
python-idle and dumps the rest. 
 
My thoughts: 
 
/usr/lib/pythonX.Y/Tools seems to be the precedent python.org is 
trying to set. Even though most of these will *not* be "import"ed 
into other Python programs, it may do just as well to make them 
available here for those that are reading through the documentation. 
Pynche, modulator, idle are made to install in site-packages and 
reworked from there. So, what's left is a bunch of random sample 
programs that people can reference. 
 
It might even do well to bring this up on Python-dev again before 
preceding.  But, following blindly, it probably should go 
into /usr/lib/pythonX.Y/Tools. 

Comment 6 Bill Nottingham 2006-08-04 20:19:36 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.