Bug 1934761 - linux-firmware-20210208-117.fc33 breaks WiFi on Raspberry Pi 4
Summary: linux-firmware-20210208-117.fc33 breaks WiFi on Raspberry Pi 4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F34BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-03-03 19:16 UTC by Benjamin Masse
Modified: 2021-03-12 01:36 UTC (History)
8 users (show)

Fixed In Version: linux-firmware-20210208-118.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-12 01:36:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Benjamin Masse 2021-03-03 19:16:02 UTC
Description of problem:
latest firmware breaks WiFi connectivity on Raspberry Pi 4

Version-Release number of selected component (if applicable):
linux-firmware-20210208-117.fc33 

How reproducible:
Always

Steps to Reproduce:
1. Update to linux-firmware-20210208-117.fc33 
2. Reboot


Actual results:
WiFi no longer available

Expected results:
WiFi connectivity preserved

Additional info:
Reproducible with kernel-5.10.x as well as with kernel-5.11.2-300.fc34 (pulled with koji)
Downgrade of linux-firmware restores WiFi connectivity.

Comment 1 Peter Robinson 2021-03-04 22:11:28 UTC
Fix landed upstream

Comment 2 Fedora Blocker Bugs Application 2021-03-04 22:12:53 UTC
Proposed as a Freeze Exception for 34-beta by Fedora user pbrobinson using the blocker tracking app because:

 WiFI has regressed on some variants of the Raspberry Pi 4 series of devices.

Comment 3 Adam Williamson 2021-03-05 22:17:27 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/282 , marking accepted.

Comment 4 Fedora Update System 2021-03-08 19:46:55 UTC
FEDORA-2021-aa6daa4fd1 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-aa6daa4fd1

Comment 5 Benjamin Masse 2021-03-09 09:48:23 UTC
Happy to report that linux-firmware-20210208-118.fc33 currently in testing restored the WiFi connectivity on my Raspberry Pi 4B 4G.

Thanks to upstream and P.B. Robinson

Comment 6 Fedora Update System 2021-03-09 22:46:12 UTC
FEDORA-2021-aa6daa4fd1 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-aa6daa4fd1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-aa6daa4fd1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2021-03-12 01:36:04 UTC
FEDORA-2021-aa6daa4fd1 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.