Bug 193497 - Adding as Cc is not possible when Keywords are filled in
Adding as Cc is not possible when Keywords are filled in
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 17:09 EDT by Robert Scheck
Modified: 2013-06-23 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 11:05:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-05-29 17:09:14 EDT
Description of problem:
Adding as Cc is not possible when Keywords are filled in. BTW, I'm using Opera 
8.5 (with JavaScript enabled, of course).

Version-Release number of selected component (if applicable):
Bugzilla Version 2.18-rh

How reproducible:
Everytime, see below.

Steps to Reproduce:
1. https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=172821
2. [x] Add Me to Cc List
3. [Save Changes]
4. "Not allowed: You tried to change the Keywords field from no value to 
FutureFeature, but only the owner or submitter of the bug, or a sufficiently 
empowered user, may change that field."
5. Fscking...I didn't change the Keywords field in any way!
6. Evil workaround would be to remove "FutureFeature" myself and re-submit, 
because Bugzilla is believing it wasn't there anyway! Oh and this workaround 
works, of course ;->
  
Actual results:
Adding as Cc is not possible when Keywords are filled in

Expected results:
Adding as Cc even when Keywords are filled in! ;-)

Additional info:
Hopefully you don't have to re-add that many Keywords for Bugreports again...
Comment 1 David Lawrence 2006-06-26 10:57:07 EDT
Strange. I am unable to reproduce this in my testing. Does it happen to you for
other bugs as well that have a keyword filled in? Is the browser somehow
emptying that field? Can you supply me the HTML source of the bug page before
submitting so I can see if the field is getting zeroed out somehow?

Thanks
Comment 2 Robert Scheck 2006-06-26 12:07:15 EDT
Yes, I'm able to reproduce this at other bug reports as well, when a keyword is 
filled in and I'm not owning the bug.

    <tr>
      <td align="right" id="header-label">
        <a href="describekeywords.cgi"><u>K</u>eywords</a>
      <td colspan="5">
        <input name="keywords" accesskey="k"
               value="FutureFeature" size="60">
      </td>
    </tr>
Comment 3 Alex Lancaster 2006-09-15 15:30:42 EDT
Yes, this happens with me as well.  It seems to happen on all bugs where the
keyword was set by a bot which changed bugs that had Severity set to
"enhancement" to bugs with Severity set to "normal" and a Keyword set to
"FutureFeature".  

For some reason bugzilla doesn't see that the Keyword is actually set and treats
it as if it being set for the first time by the person modifying the bug.

The workaround is to simply remove the "FutureFeature" keyword completely.  You
can then modify the bug.  Of course, that's not really acceptable because it
loses that keyword completely.
Comment 4 David Lawrence 2008-09-16 12:54:35 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Note You need to log in before you can comment on or make changes to this bug.