Bug 193527 - TeXmacs segfaults on start
TeXmacs segfaults on start
Product: Fedora
Classification: Fedora
Component: TeXmacs (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
Depends On:
Blocks: FE6Target
  Show dependency treegraph
Reported: 2006-05-29 21:54 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-12 17:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The output from "strace -f texmacs" (321.67 KB, text/plain)
2006-05-30 09:10 EDT, Horst H. von Brand
no flags Details
Output of "strace -f texmacs" here (306.66 KB, text/plain)
2006-08-11 19:26 EDT, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2006-05-29 21:54:37 EDT
Description of problem:
Starting texmacs (for the first time ever!) just gives a segmentation fault.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run texmacs from a Gnome terminal
Actual results:
Segmentation fault

Expected results:
Anything else...

Additional info:
When trying to start it via the GUI, a "Starting TeXmacs..." icon shows up on
the lower menubar, but it goes away after a while and nothing else shows up.
Comment 1 Gérard Milmeister 2006-05-30 04:17:12 EDT
* What is the output on the terminal?
* Run with "strace -f texmacs" and send the output.
Comment 2 Horst H. von Brand 2006-05-30 09:10:01 EDT
Created attachment 130226 [details]
The output from "strace -f texmacs"
Comment 3 Horst H. von Brand 2006-05-30 09:10:56 EDT
* What is the output on the terminal?

Just "Segmentation fault"
Comment 4 Gérard Milmeister 2006-05-30 10:25:34 EDT
It seems the problem occurs while loading scheme init files.
Rawhide has guile 1.8 instead of guile 1.6.7, so I had to
patch a bit to make the thing compile. Apparently this broke
something. I have no rawhide installation here, so I can't
really test it. Upstream does not yet support guile 1.8
and there has been no discussion about it apart one question
regarding compilation errors which hasn't been answered.
So, I consider TeXmacs broken on rawhide. I think it is
best to request removal from the repositories, unless
you would come up with a solution. I am sorry, I cannot
do more than wait for a new upstream release supporting guile 1.8.
Comment 5 Horst H. von Brand 2006-08-11 19:26:53 EDT
Created attachment 134072 [details]
Output of "strace -f texmacs" here

Again, just "Segmentation  fault" when running in a gnome-terminal.
Comment 6 Vedran Miletić 2006-09-30 05:16:52 EDT
TeXmacs should fix this, according to logs on upstream CVS. Can anyone
check that?
Comment 7 Gérard Milmeister 2006-11-12 17:20:44 EST
TeXmacs does not work with guile 1.8.0 from FC-6. It will not be available for
FC-6 and current devel until this problem is solved upstream.

Note You need to log in before you can comment on or make changes to this bug.