Bug 193530 - support any hooks to invoke setkeycodes etc.
support any hooks to invoke setkeycodes etc.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 01:39 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 04:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-05-30 01:39:13 EDT
Description of problem:
According to Bug #192637 rejected, we need any hooks to invoke setkeycodes to
support a Hangul keyboard, which is actually the same as US keyboard except
having Hanja/Hangul keys and it will be available after setkeycodes 71 122 72
133. I'm filing this so that system-config-keyboard would be the best place to
support this feature since most people probably configures their keyboard
settings by system-config-keyboard.

Version-Release number of selected component (if applicable):
1.2.7-1.1

How reproducible:
always

Steps to Reproduce:
1.run s-c-keyboard
2.
3.
  
Actual results:
no hangul keyboard.

Expected results:
should be added a hangul keyboard there and Hanja/Hangul keys should be also
available by invoking setkeycodes.

Additional info:
Comment 1 Caius Chance 2006-09-29 00:51:47 EDT
Change to kbd component as us.map.gz is in kbd:

`rpm -qf /lib/kbd/keymaps/i386/qwerty`

kbd-1.12-17
Comment 2 Akira TAGOH 2006-09-29 04:28:20 EDT
Fixed in kernel. so no need to do setkeycodes anymore.

Note You need to log in before you can comment on or make changes to this bug.